Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 109387 - key import issues w/ up2date
Summary: key import issues w/ up2date
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks: EasyFix-Tracker
TreeView+ depends on / blocked
 
Reported: 2003-11-07 12:37 UTC by Chris Ricker
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-08-24 20:58:53 UTC


Attachments (Terms of Use)

Description Chris Ricker 2003-11-07 12:37:20 UTC
[root@skuld root]# up2date --nox -u
Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent
downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY

[root@skuld root]# rpm --import /usr/share/rhn/RPM-GPG-KEY
[root@skuld root]# up2date --nox -u
Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent
downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY

[root@skuld root]# 

At a minimum, the instructions appear very wrong ;-)

This actually happens with the GUI-ified version as well. If I import
there, it still gives me the "key missing" message when I run a second
time

Comment 1 Chris Ricker 2003-11-07 12:40:24 UTC
The problem isn't w/ keys not getting imported -- the rpm side seems
to work fine:

[root@skuld root]# rpm -qa | grep ^gpg
gpg-pubkey-897da07a-3c979a7f
gpg-pubkey-e418e3aa-3f439953
gpgme-0.4.0-0.fdr.2.rh90.93
[root@skuld root]# rpm --import /usr/share/rhn/RPM-GPG-KEY
[root@skuld root]# rpm -qa | grep ^gpg
gpg-pubkey-db42a60e-37ea5438
gpg-pubkey-897da07a-3c979a7f
gpg-pubkey-e418e3aa-3f439953
gpgme-0.4.0-0.fdr.2.rh90.93
[root@skuld root]# up2date --nox -u
Your GPG keyring does not contain the Red Hat, Inc. public key.
Without it, you will be unable to verify that packages Update Agent
downloads
are securely signed by Red Hat.

Your Update Agent options specify that you want to use GPG.

To install the key, run the following as root:

    rpm --import /usr/share/rhn/RPM-GPG-KEY

[root@skuld root]# 

Comment 2 Chris Ricker 2003-11-07 12:42:18 UTC
Ah, there's now an additional key

[root@skuld root]# rpm --import /usr/share/rhn/RPM-GPG-KEY-fedora
[root@skuld root]# up2date --nox -u

Fetching package list for channel: fedora-core-1...

Fetching
http://fedora.redhat.com/releases/fedora-core-1/headers/header.info...
########################################

Fetching package list for channel: updates-released...

Fetching
http://fedora.redhat.com/updates/released/fedora-core-1/headers/header.info...
########################################

Fetching Obsoletes list for channel: fedora-core-1...

Fetching Obsoletes list for channel: updates-released...

Fetching rpm headers...

Name                                    Version        Rel     
----------------------------------------------------------

All packages are currently up to date
[root@skuld root]# 

The text needs to be fixed (and the key importing logic in the gui)

up2date-4.1.16-1




Note You need to log in before you can comment on or make changes to this bug.