Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1092921 - perl-Perl-Critic make check failing on ppc64le archi
Summary: perl-Perl-Critic make check failing on ppc64le archi
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Perl-Critic
Version: rawhide
Hardware: noarch
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-04-30 09:15 UTC by Michel Normand
Modified: 2014-05-02 08:42 UTC (History)
3 users (show)

Fixed In Version: perl-Perl-Critic-1.121-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-02 05:36:35 UTC


Attachments (Terms of Use)
perl-Perl-Critic.build.failure.log (deleted)
2014-04-30 09:15 UTC, Michel Normand
no flags Details

Description Michel Normand 2014-04-30 09:15:52 UTC
Created attachment 891090 [details]
perl-Perl-Critic.build.failure.log

Description of problem: perl-Perl-Critic make check failing on ppc64le archi


Version-Release number of selected component (if applicable):
perl-Perl-Critic-1.121-1.fc21

How reproducible:


Steps to Reproduce: (on ppc64le archi)
1.fedpkg clone -a perl-Perl-Critic; export pkg='perl-Perl-Critic';
2.cd $pkg; fedpkg srpm; mock --init --uniqueext="$pkg-XS"
3.mock --no-clean --with=check  --uniqueext="$pkg-XS" ./$pkg*.src.rpm

Actual results:
=== extract of the attached log
#   Failed test 'use Readonly::XS;'
#   at xt/author/82_optional_modules.t line 40.
#     Tried to use 'Readonly::XS'.
#     Error:  Attempt to reload Readonly/XS.pm aborted.
# Compilation failed in require at xt/author/82_optional_modules.t line 40.
# BEGIN failed--compilation aborted at xt/author/82_optional_modules.t line 40.
# Looks like you failed 1 test of 6.
xt/author/82_optional_modules.t ............... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/6 subtests
===


Expected results: all tests should pass


Additional info:
There is no such problem if same build tried on a ppc64 archi.

Comment 1 Michel Normand 2014-04-30 09:21:22 UTC
I tried to investigate the reported error but with no success as detailed in http://www.mail-archive.com/perl-xs@perl.org/msg02580.html
any suggestion are welcome.

Comment 2 Paul Howarth 2014-04-30 10:06:17 UTC
Well, Readonly::XS should never really be "use"d itself, only pulled in via Readonly, which is made quite clear in its documentation.

There is a request in https://rt.cpan.org/Public/Bug/Display.html?id=49576 to allow this but that request has gone about 5 years without a response.

It's probably easiest just to stop the xt/author/82_optional_modules.t test from trying to do this. The test also fails in Rawhide x86_64 so it's not an arch-specific issue.

Comment 3 Paul Howarth 2014-04-30 23:30:15 UTC
Please give perl-Perl-Critic-1.121-2.fc21 a try.

Comment 4 Paul Howarth 2014-05-01 13:51:58 UTC
The issue is triggered by the update of perl-Readonly to version 1.04 in Rawhide, though that happened back in November 2013 so I'm surprised you've seen a working build since. Or was your ppc64 build still pulling in Readonly 1.03 for some reason?

https://github.com/Perl-Critic/Perl-Critic/issues/570

Comment 5 Michel Normand 2014-05-02 05:35:05 UTC
(In reply to Paul Howarth from comment #3)
> Please give perl-Perl-Critic-1.121-2.fc21 a try.

mock build (and check) do succeed with this new release.


Note You need to log in before you can comment on or make changes to this bug.