Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1092630 - Requesting that a Qlogic firmware file be added to the RHEV-H 6.5 image.
Summary: Requesting that a Qlogic firmware file be added to the RHEV-H 6.5 image.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor
Version: 3.3.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1123329 1135780 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-29 15:28 UTC by Gordon Watson
Modified: 2018-12-05 18:24 UTC (History)
19 users (show)

Fixed In Version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso
Doc Type: Enhancement
Doc Text:
With this update, QLogic firmware has been updated to support the most recent hardware.
Clone Of:
: 1135780 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:47:13 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 633553 None None None Never
Red Hat Product Errata RHBA-2015:0201 normal SHIPPED_LIVE rhev-hypervisor bug fix and enhancement update for RHEV 3.5.0 2015-02-11 22:38:04 UTC
Red Hat Knowledge Base (Solution) 873453 None None None Never

Description Gordon Watson 2014-04-29 15:28:02 UTC
Description of problem:

We have a customer who has upgraded their Qlogic firmware, but because their 'initramfs' doesn't contain the same version then they get messages reported saying;

"qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update."

This is resolved by adding the latest firmware version, '7.03.00 ', via file 'ql2500_fw.bin' to '/lib/firmware' and then updating the 'initramfs' with this.

Doing this on RHEL is straightforward. However, on RHEV-H this is not so. So, can we add this version of the Qlogic firmware to RHEV-H ?


Version-Release number of selected component (if applicable):

RHEV-H 6.5 20140407.0


How reproducible:

This is reproducible with the specific model of Qlogic HBA.


Steps to Reproduce:
1.
2.
3.

Actual results:

"qla2xxx 0000:1b:00.0: vpd r/w failed" reported.


Expected results:

No such errors reported.

Additional info:

See subsequent comments for what I done so far to test and address this in the interim.

Comment 5 cshao 2014-05-12 03:42:01 UTC
Hi gwatson,

RHEV-H QE can't reproduce this bug with our lab's machine. Could you please provide more details hardware info to us for better testing this case?
And please confirm us which version of rhev-h you are using on which this firmware upgrade is required ?

Thanks!

Test machine:
IBM System x3650 M4 
ql2400-firmware-7.00.01-1.el6.noarch

Test version:
RHEV-H 6.5-20140324.0
RHEV-H 6.5 20140407.0
ovirt-node-3.0.1-18.el6_5.8.noarch
kernel-2.6.32-431.11.2.el6.x86_64


# grep -v "zZzZ" /sys/class/scsi_host/host*/model_name | grep QL
/sys/class/scsi_host/host1/model_name:QLE2562
/sys/class/scsi_host/host2/model_name:QLE2562

# grep -v "zZzZ" /sys/class/scsi_host/host*/fw_version
/sys/class/scsi_host/host1/fw_version:7.00.01 (90d5)
/sys/class/scsi_host/host2/fw_version:7.00.01 (90d5)

# grep -v "zZzZ" /sys/class/fc_host/host*/symbolic_name
/sys/class/fc_host/host1/symbolic_name:QLE2562 FW:v7.00.01 DVR:v8.05.00.03.06.5-k2
/sys/class/fc_host/host2/symbolic_name:QLE2562 FW:v7.00.01 DVR:v8.05.00.03.06.5-k2

# ls -l /lib/firmware/ql*.bin
-rw-r--r--. 1 root root  76802 2009-12-03 15:10 /lib/firmware/ql2100_fw.bin
-rw-r--r--. 1 root root  84566 2009-12-03 14:58 /lib/firmware/ql2200_fw.bin
-rw-r--r--. 1 root root 125088 2009-12-03 15:06 /lib/firmware/ql2300_fw.bin
-rw-r--r--. 1 root root 135896 2009-12-03 15:06 /lib/firmware/ql2322_fw.bin
-rw-r--r--. 1 root root 259052 2013-08-14 13:34 /lib/firmware/ql2400_fw.bin
-rw-r--r--. 1 root root 261940 2013-08-14 13:35 /lib/firmware/ql2500_fw.bin


Test steps:
1. Upgrade Qlogic firmware to 7.00.01 
2. Install RHEV-H.
3. Focus on /var/log/dmesg.

Test result:
Can't see the bug's error in dmesg.

Comment 6 Dwight (Bud) Brown 2014-05-12 19:43:37 UTC
The only customer h/w info I have is the following.  Is the card the same pci device id and hardware rev(02)?

DMI: IBM System x3650 M4 -[7915J2G]-/00J6520, BIOS -[VVE136AUS-1.60]- 12/12/2013
# lspci -v -s 1b:00.0
1b:00.0 Fibre Channel: QLogic Corp. ISP2532-based 8Gb Fibre Channel to PCI Express HBA (rev 02)
        Subsystem: QLogic Corp. Device 015d
        Flags: bus master, fast devsel, latency 0, IRQ 40
        I/O ports at 3c00 [size=256]
        Memory at c44fc000 (64-bit, non-prefetchable) [size=16K]
        Expansion ROM at ca300000 [disabled] [size=256K]
        Capabilities: [44] Power Management version 3
        Capabilities: [4c] Express Endpoint, MSI 00
        Capabilities: [88] MSI: Enable- Count=1/32 Maskable- 64bit+
        Capabilities: [98] Vital Product Data
        Capabilities: [a0] MSI-X: Enable+ Count=2 Masked-
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [138] Power Budgeting <?>
        Kernel driver in use: qla2xxx
        Kernel modules: qla2xxx


qla2xxx [0000:00:00.0]-0005: QLogic Fibre Channel HBA Driver: 8.05.00.03.06.5-k2.
qla2xxx [0000:1b:00.0]-00fb:1: QLogic QLE2562 - QLogic 8Gb FC Dual-port HBA for System x.
qla2xxx [0000:1b:00.0]-00fc:1: ISP2532: PCIe (5.0GT/s x8) @ 0000:1b:00.0 hdma+ host#=1 fw=7.00.01 (90d5).
:
.
qla2xxx [0000:1b:00.0]-1019:1: Thermal not supported through ISP.
qla2xxx [0000:1b:00.0]-1150:1: Thermal not supported by this card (ignoring further requests).
qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
qla2xxx 0000:1b:00.0: vpd r/w failed.  This is likely a firmware bug on this device.  Contact the card vendor for a firmware update.
:
.

Updating the f/w to 7.03.00  stops the above events from flooding the dmesg file during boot.

Comment 8 Ying Cui 2014-05-13 10:43:11 UTC
Make this bug clear on QE side to verify this bug.
1. The detail issue is fixed on ql2500-firmware-7.03.00-1.el6 package, see bug 1076497.
2. Customer has tested RHEV-H ISO pass which built by edit-node and contains this version of the firmware 7.03.00.
3. Standard RHEV-H should include the ql2500-firmware-7.03.00-1.el6 package into build to avoid qla2xxx error report.

Comment 13 cshao 2014-09-03 09:10:07 UTC
Test version:
rhev-hypervisor6-6.5-20140821.1.el6ev
ovirt-node-3.0.1-18.el6.14.noarch
ql2500-firmware-7.03.00-1.el6_5.noarch

According fabiand's comment, ql2500-firmware-7.03.00-1.el6_5.noarch is included by rhev-hypervisor6-6.5-20140821.1.el6ev, so the bug should be fixed.

# rpm -qa | grep ql2500
ql2500-firmware-7.03.00-1.el6_5.noarch


Thanks!

Comment 14 cshao 2015-01-14 03:36:31 UTC
Test version:
RHEVH6.6
rhev-hypervisor6-6.6-20150112.0
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el6.noarch
ql2500-firmware-7.03.00-1.el6.noarch

# rpm -qa| grep ql2500
ql2500-firmware-7.03.00-1.el6.noarch

===================================================
RHEVH7.0
rhev-hypervisor7-7.0-20150112.0
ovirt-node-3.1.0-0.42.20150109gitd06b7c5.el7.noarch
# rpm -qa | grep ql2500
#

Hi Fabiand,

The package "ql2500-firmware-7.03.00-1.el6.noarch" is included by rhev-hypervisor6-6.6-20150112.0, but RHEV-H7.0 didn't include "ql2500-firmware".

I noticed that the bug fixed in version: rhev-hypervisor6-6.6-20141218.0.iso rhev-hypervisor7-7.0-20141218.0.iso. 

So can I verify this bug directly according the test result of rhevh6.6? 
Or assigned this bug until RHEVH7.0 include the "ql2500-firmware" package?

Thanks!

Comment 15 Fabian Deutsch 2015-01-14 11:50:01 UTC
As far as I can tell the package got removed/merged into another package in RHEL 7.

Thus it is fine to only verify this bug on RHEV-H 6.6.

Comment 16 cshao 2015-01-15 02:28:18 UTC
Verify this bug according #c14 & #c15

Comment 18 errata-xmlrpc 2015-02-11 17:47:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0201.html


Note You need to log in before you can comment on or make changes to this bug.