Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1092397 - [RFE] Warn when answer file does not exist
Summary: [RFE] Warn when answer file does not exist
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.core
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ---
: 1.3.0
Assignee: Alon Bar-Lev
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
: 1224720 (view as bug list)
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-29 08:50 UTC by Petr Beňas
Modified: 2016-08-17 07:35 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-12 18:50:20 UTC
oVirt Team: Infra
dfediuck: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27430 master MERGED config: warn if config append is missing Never

Description Petr Beňas 2014-04-29 08:50:38 UTC
Description of problem:
[root@pb-rh34 ~]# ls nonexistent
ls: cannot access nonexistent: No such file or directory
[root@pb-rh34 ~]# rhevm-setup --config-append=nonexistent
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140429104643.log
          Version: otopi-1.2.0 (otopi-1.2.0-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
<snip/>

Version-Release number of selected component (if applicable):
rhevm-setup-3.4.0-0.15.beta3.el6ev.noarch

Actual results:
Wrong filename is silently ignored

Expected results:
A wargning.

Comment 1 Sandro Bonazzola 2014-05-06 06:14:47 UTC
I think this  should be solved at otopi level in core.config plugin.
Files specified as additional configuration should show a warning to the user if not existing.

Comment 2 Alon Bar-Lev 2014-05-06 18:04:13 UTC
by design configuration is allowed to be missing.

the search for configuration is:

1. file: configuration name
2. directory: configuration name + '.d/*.conf'

missing configuration is valid.

I added a warning for missing config append, although not very happy... as I can think of many scenarios in which this is valid.

Comment 3 Alon Bar-Lev 2014-05-06 18:59:41 UTC
Not sure how do I set 3.4.1 without robot revert.

Comment 5 Sandro Bonazzola 2014-05-07 06:59:19 UTC
(In reply to Alon Bar-Lev from comment #3)
> Not sure how do I set 3.4.1 without robot revert.

You need 3.5.0 and 3.4.z flags request.

Comment 6 Alon Bar-Lev 2014-05-07 07:07:42 UTC
(In reply to Sandro Bonazzola from comment #5)
> (In reply to Alon Bar-Lev from comment #3)
> > Not sure how do I set 3.4.1 without robot revert.
> 
> You need 3.5.0 and 3.4.z flags request.

Probably I have no permissions as I did not see the 3.4.z.

Thank you for taking care of that.

Comment 7 Yedidyah Bar David 2016-08-17 07:35:18 UTC
*** Bug 1224720 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.