Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1092361 - Params --succeedd is not autocompleted in 'action step'.
Summary: Params --succeedd is not autocompleted in 'action step'.
Keywords:
Status: CLOSED DUPLICATE of bug 1087916
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Shai Revivo
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-29 07:24 UTC by Ondra Machacek
Modified: 2016-02-10 19:28 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-29 09:12:09 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Description Ondra Machacek 2014-04-29 07:24:22 UTC
Description of problem:
Params --succeeded is not autocompleted in 'action step'.

Version-Release number of selected component (if applicable):
rhevm-cli-3.4.0.6-3.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
action step '98d24b8c-4de1-4429-9b5d-0a38cac98ceb' end --job-identifier '0b8cc7f7-2b6a-4b5c-a15f-9a9dc0eca025'   --grace_period-expiry 10 --async false <TAB><TAB>

Actual results:
async                correlation_id       force                grace_period-expiry  status-state         

Expected results:
async                correlation_id       force                grace_period-expiry  status-state      *succeeded*


Additional info:

Comment 1 Juan Hernández 2014-04-29 09:12:09 UTC
This happens because the "succeeded" parameter isn't documented in the RESTAPI metadata. It needs to be fixed in the metadata, something like this:

diff --git a/backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml b/backend/manager/modules/resta
index 7e5fc87..6ae37d2 100644
--- a/backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
+++ b/backend/manager/modules/restapi/interface/definition/src/main/resources/rsdl_metadata.yaml
@@ -4615,7 +4615,8 @@ actions:
       parameterType: Action
       signatures:
       - mandatoryArguments: {}
-        optionalArguments: {action.force: 'xs:boolean', action.status.state: 'xs:string', action.async: 'xs:boolean', action.grace_per
+        optionalArguments: {action.force: 'xs:boolean', action.status.state: 'xs:string', action.async: 'xs:boolean', action.grace_per
+          succeeded: 'xs:boolean'}
         description: invoke the command to end the specified step of an external job with an optional agrument to force the operation
     urlparams: {}
     headers:

But I'm not sure if this parameter should be optional or mandatory. We already have bug 1087916 for that, which is more severe. As the fix for that bug will fix this as well, I'm closing this as duplicate.

*** This bug has been marked as a duplicate of bug 1087916 ***


Note You need to log in before you can comment on or make changes to this bug.