Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1091685 - [TEXT] Attaching disk to vm in 'reboot in progress' state returns a confusing Operation failed message
Summary: [TEXT] Attaching disk to vm in 'reboot in progress' state returns a confusing...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Idan Shaby
QA Contact: Raz Tamir
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-27 09:18 UTC by Raz Tamir
Modified: 2016-02-10 18:39 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-16 19:11:03 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 28257 master MERGED core: Confusing message fix Never

Description Raz Tamir 2014-04-27 09:18:43 UTC
Description of problem:
Trying to attach a disk to vm that is in 'Reboot in progress' state ends up with <fault></fault> object:
<fault>
    <reason>Operation Failed</reason>
    <detail>[Cannot attach Virtual Machine Disk because it is in Reboot in    Progress status.]</detail>
</fault>.
The details is confusing: from the details it appears that the disk is in 'Reboot in Progress' status, which is incorrect. 


Version-Release number of selected component (if applicable):
rhevm-3.4.0-0.13.beta3.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. attach disk to vm that is in reboot status
2.
3.

Actual results:
<fault>
    <reason>Operation Failed</reason>
    <detail>[Cannot attach Virtual Machine Disk because it is in Reboot in    Progress status.]</detail>
</fault>.

Expected results:
<fault>
    <reason>Operation Failed</reason>
    <detail>[Cannot attach Disk to Virtual Machine because it is in Reboot in Progress status.]</detail>
</fault>.

Additional info:

Comment 1 Allon Mureinik 2014-04-27 14:21:08 UTC
Jodi, can you please approve the message in the expected result above (or alternatively, suggest a better one? `-)).

Thanks!

Comment 2 Jodi Biddle 2014-04-27 22:21:42 UTC
[Cannot attach Disk to Virtual Machine because its status is still Reboot in Progress] 

Hope that makes it clearer :)

Comment 3 Raz Tamir 2014-06-15 12:18:39 UTC
Verified - ovirt-engine-3.5.0-0.0.master.20140605145557.git3ddd2de.el6.noarch

As expected:
<fault>
<reason>Operation Failed</reason>
<detail>
[Cannot attach Virtual Machine Disk because the VM is in Reboot in Progress status.]
</detail>
</fault>

Comment 4 Allon Mureinik 2015-02-16 19:11:03 UTC
RHEV-M 3.5.0 has been released, closing this bug.

Comment 5 Allon Mureinik 2015-02-16 19:11:18 UTC
RHEV-M 3.5.0 has been released, closing this bug.


Note You need to log in before you can comment on or make changes to this bug.