Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1091282 - [scheduler] Error msg during migration is not clear
Summary: [scheduler] Error msg during migration is not clear
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Martin Sivák
QA Contact: Artyom
URL:
Whiteboard: sla
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-25 09:42 UTC by Pavel Stehlik
Modified: 2016-02-10 20:14 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:16:15 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)

Description Pavel Stehlik 2014-04-25 09:42:44 UTC
Description of problem:
Migrate VM to host where is not enough memory.

UI message:
 Migration failed (VM: mp-rhevm33, Source: slot-2.rhev.lab.eng.brq.redhat.com, Destination: <UNKNOWN>).
Log:
...
014-04-25 11:29:11,523 INFO  [org.ovirt.engine.core.bll.scheduling.SchedulingManager] (pool-5-thread-49) [26a9039e] Candidate host srh-02.rhev.lab.eng.brq.redhat.com (99501ea2-c165-42c2-bce3-a235ac6980f4) was filtered out by VAR__FILTERTYPE__INTERNAL filter Memory (correlation id: 26a9039e)
2014-04-25 11:29:11,523 ERROR [org.ovirt.engine.core.bll.MigrateVmToServerCommand] (pool-5-thread-49) [26a9039e] Command org.ovirt.engine.core.bll.MigrateVmToServerCommand throw Vdc Bll exception. With error message VdcBLLException: RESOURCE_MANAGER_VDS_NOT_FOUND (Failed with error RESOURCE_MANAGER_VDS_NOT_FOUND and code 5004)
...

Version-Release number of selected component (if applicable):
rhevm-backend-3.3.2-0.50.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. try to migrate VM to host where is not enough memory (select specific destination host)
2.
3.

Actual results:
Useless message in UI, not clear message in log. 

Expected results:
Clear message about destination host & clear reason of failure.


Additional info:
engine.log:
======
2014-04-25 11:29:11,489 INFO  [org.ovirt.engine.core.bll.MigrateVmToServerCommand] (pool-5-thread-49) [26a9039e] Running command: MigrateVmToServerCommand internal: false. Entities affected :  ID: 94cbf06f-91f3-4eb2-ac85-67375917d795 Type: VM
2014-04-25 11:29:11,523 INFO  [org.ovirt.engine.core.bll.scheduling.SchedulingManager] (pool-5-thread-49) [26a9039e] Candidate host srh-02.rhev.lab.eng.brq.redhat.com (99501ea2-c165-42c2-bce3-a235ac6980f4) was filtered out by VAR__FILTERTYPE__INTERNAL filter Memory (correlation id: 26a9039e)
2014-04-25 11:29:11,523 ERROR [org.ovirt.engine.core.bll.MigrateVmToServerCommand] (pool-5-thread-49) [26a9039e] Command org.ovirt.engine.core.bll.MigrateVmToServerCommand throw Vdc Bll exception. With error message VdcBLLException: RESOURCE_MANAGER_VDS_NOT_FOUND (Failed with error RESOURCE_MANAGER_VDS_NOT_FOUND and code 5004)
2014-04-25 11:29:11,527 ERROR [org.ovirt.engine.core.bll.MigrateVmToServerCommand] (pool-5-thread-49) [26a9039e] Transaction rolled-back for command: org.ovirt.engine.core.bll.MigrateVmToServerCommand.
2014-04-25 11:29:11,535 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (pool-5-thread-49) [26a9039e] Correlation ID: 26a9039e, Job ID: 95c3ea4a-c642-4029-91ba-eff2a52f109f, Call Stack: null, Custom Event ID: -1, Message: Migration failed  (VM: mp-rhevm33, Source: slot-2.rhev.lab.eng.brq.redhat.com, Destination: <UNKNOWN>).
2014-04-25 11:29:11,542 INFO  [org.ovirt.engine.core.bll.MigrateVmToServerCommand] (pool-5-thread-49) [26a9039e] Lock freed to object EngineLock [exclusiveLocks= key: 94cbf06f-91f3-4eb2-ac85-67375917d795 value: VM
, sharedLocks= ]
2014-04-25 11:29:42,571 INFO  [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler_Worker-83) [36456d] OnVdsDuringFailureTimer of vds srh-02.rhev.lab.eng.brq.redhat.com entered. Attempts after -127

Comment 1 Martin Sivák 2014-07-23 09:13:05 UTC
Well the log contains a clear message (for me):

Candidate host srh-02.rhev.lab.eng.brq.redhat.com (99501ea2-c165-42c2-bce3-a235ac6980f4) was filtered out by VAR__FILTERTYPE__INTERNAL filter Memory

We improved the logging so this seems to be already fixed. Can you check with the current 3.5 build?

Comment 3 Artyom 2014-08-07 12:30:45 UTC
Verified on ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch
Error message:
Error while executing action:

test_mem:

    Cannot run VM. There is no host that satisfies current scheduling constraints. See below for details:
    The host alma06.qa.lab.tlv.redhat.com did not satisfy internal filter Memory because it has insufficient free memory to run the VM.

Comment 4 Eyal Edri 2015-02-17 17:16:15 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.