Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1090434 - UI crashes when no bond name is given
Summary: UI crashes when no bond name is given
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Joey Boggs
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 986285 1150377
Blocks: 1118297 1120061 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-23 10:29 UTC by haiyang,dong
Modified: 2016-02-10 20:11 UTC (History)
17 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.13
Doc Type: Bug Fix
Doc Text:
Clone Of: 986285
: 1120061 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:55:52 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 27110 master MERGED disable transaction of bond if unset bond.name and bond.slaves.selected Never

Description haiyang,dong 2014-04-23 10:29:15 UTC
+++ This bug was initially created as a clone of Bug #986285 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select <cretae bond> in UI
2. modify options filed and select a nic (leave the bond name field empty)
3. Press <Save>

Actual results:
UI crashes

Expected results:
Dialog showing the error (missing bond name)

Additional info:
Screenshot in 984410 in attachment 773573 [details]

--- Additional comment from Ryan Barry on 2014-04-21 12:52:42 EDT ---

This will need to wait for a validation rework

Comment 1 haiyang,dong 2014-04-23 10:32:57 UTC
This issue also could reproduce in the follow version:
ovirt-node-3.0.1-18.el6_5.8.noarch
rhevh-6.5-20140317.0.iso

so need to clone it from upstream into downstream to track in rhevh

Comment 5 haiyang,dong 2014-11-17 08:09:46 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Test steps:
1. Select <cretae bond> in UI
2. modify options filed and select a nic (leave the bond name field empty)
3. Press <Save>

Now no UI crashes, also it prompt "There were no changes, nothing to do." 

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED".

Comment 7 errata-xmlrpc 2015-02-11 20:55:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.