Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1090395 - [Selectors] ExactNumeric and ApporoxNumeric does not accept prefix + sign
Summary: [Selectors] ExactNumeric and ApporoxNumeric does not accept prefix + sign
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: 3.0
: ---
Assignee: Andrew Stitcher
QA Contact: Zdenek Kraus
URL:
Whiteboard:
Depends On:
Blocks: 453539
TreeView+ depends on / blocked
 
Reported: 2014-04-23 08:45 UTC by Zdenek Kraus
Modified: 2014-09-24 15:11 UTC (History)
4 users (show)

Fixed In Version: qpid-cpp-0.22-43
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-24 15:11:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5804 None None None Never
Red Hat Product Errata RHEA-2014:1296 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description Zdenek Kraus 2014-04-23 08:45:02 UTC
Description of problem:
when number starting with + is supplied to selector, it is evaluated as Illegal selector.

Version-Release number of selected component (if applicable):
qpid-cpp-server-0.22-37

How reproducible:
100%

Steps to Reproduce:
1. ./drain "q;{create: always, link:{selector:\"a = +1\"}}"
2. ./drain "q;{create: always, link:{selector:\"a = +1e1\"}}"

Actual results:
[1]
2014-04-23 10:39:14 [Client] warning Broker closed connection: 501, Illegal selector: '+': expected literal or identifier
framing-error: Illegal selector: '+': expected literal or identifier

[2]
2014-04-23 10:40:00 [Client] warning Broker closed connection: 501, Illegal selector: '+': expected literal or identifier
framing-error: Illegal selector: '+': expected literal or identifier

Expected results:
selector should accept these numbers

Additional info:

Comment 1 Andrew Stitcher 2014-06-09 13:25:33 UTC
This is now fixed on the qpid trunk as of r1601372

Comment 2 Zdenek Kraus 2014-06-26 08:42:18 UTC
This deferred bug is covered by automated test and it already is in POST status, please consider returning it to 3.0.0, it will be much less effort to verify it than removing and verifying it's not present.

Comment 4 Zdenek Kraus 2014-07-16 08:51:18 UTC
Tested on RHEL 6.5 i686 and x86_64 with following packages:

qpid-cpp-client-0.22-43
qpid-cpp-client-devel-0.22-43
qpid-cpp-client-devel-docs-0.22-43
qpid-cpp-server-0.22-43
qpid-cpp-server-devel-0.22-43
qpid-cpp-server-linearstore-0.22-43
qpid-cpp-server-xml-0.22-43


Works as expected.

Comment 5 errata-xmlrpc 2014-09-24 15:11:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.