Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1088172 - [engine-log-collector] problem with sos3 on rhel7 as general.all_logs no longer exist
Summary: [engine-log-collector] problem with sos3 on rhel7 as general.all_logs no long...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1060383 1099916 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-16 07:48 UTC by Jiri Belka
Modified: 2015-02-11 17:45 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
All_logs collection has been re-enabled on sos version 3.0 and higher, with the addition of the logs plug-in and 'logs.all_logs=True'.
Clone Of:
: 1099916 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:45:59 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0193 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2015-02-11 22:35:42 UTC
oVirt gerrit 26853 master MERGED sos: re-enable all_logs collection on sos >= 3.0 Never
oVirt gerrit 27850 ovirt-log-collector-3.4 MERGED sos: re-enable all_logs collection on sos >= 3.0 Never

Description Jiri Belka 2014-04-16 07:48:08 UTC
Description of problem:
found in BZ1060383, see that BZ for all comments if needed.

fail, vdsm3-4.14.6-0.el7ev.x86_64

# engine-log-collector --no-postgresql -H 10.34.63.222 -v
...snip...
INFO: collecting information from 10.34.63.222
DEBUG: calling(['/usr/bin/ssh', '-n', '-p', '22', '-i', '/etc/pki/ovirt-engine/keys/engine_id_rsa', '-oStrictHostKeyChecking=no', '-oServerAliveInterval=600', 'root@10.34.63.222', "\nVERSION=`/bin/rpm -q --qf '[%{VERSION}]' sos | /bin/sed 's/\\.//'`;\nif [ $VERSION -ge 22 ]; then\n    /usr/sbin/sosreport  --batch -k general.all_logs=True         -o libvirt,vdsm,general,networking,hardware,process,yum,filesys,devicemapper,selinux,kernel,memory,rpm\nelif [ $VERSION -ge 17 ]; then\n    /usr/sbin/sosreport  --no-progressbar -k general.all_logs=True         -o vdsm,general,networking,hardware,process,yum,filesys\nelse\n    /bin/echo No", 'valid', 'version', 'of', 'sosreport', 'found. 1>&2\n    exit 1\nfi\n'])
DEBUG: returncode(0)
DEBUG: STDOUT(
sosreport (version 3.0)

)
DEBUG: STDERR(Error reading response length from authentication socket.^M
no such option "all_logs" for plugin (general)
)
DEBUG: message(list index out of range)
DEBUG: parse_sosreport_stdout: Traceback (most recent call last):
  File "/usr/bin/engine-log-collector", line 530, in parse_sosreport_stdout
    if fileAry[0] is not None and len(fileAry) > 0:
IndexError: list index out of range

ERROR: Failed to collect logs from: 10.34.63.222; Could not parse sosreport output to determine filename
DEBUG: Traceback (most recent call last):
DEBUG:   File "/usr/bin/engine-log-collector", line 709, in run
DEBUG:     self.parse_sosreport_stdout(stdout)
DEBUG:   File "/usr/bin/engine-log-collector", line 566, in parse_sosreport_stdout
DEBUG:     "Could not parse sosreport output to determine filename"
DEBUG: Exception: Could not parse sosreport output to determine filename
...snip...
DEBUG: STDOUT(2c81e0afb74f4002eb4708a5c9c62e58  /tmp/sosreport-LogCollector-20140415170959.tar.xz
)
DEBUG: STDERR()
INFO: Log files have been collected and placed in /tmp/sosreport-LogCollector-20140415170959.tar.xz.
The MD5 for this file is 2c81e0afb74f4002eb4708a5c9c62e58 and its size is 43.5M
# echo $?
2

missing data from host:

# tar tJvf /tmp/sosreport-LogCollector-20140415170959.tar.xz | grep '10.34.63.222.*tar.xz'
#

> (In reply to Bryn M. Reeves from comment #10)
> In reply to comment #8 - it's not really clear what's happening here.
> Clearly engine-log-collector got something it didn't expect in the output
> from the remote sos command but without seeing what the output was it's hard
> to say what may have caused it.
> 
> Note that there's been some reorganisation of plugins in 3.0 - e.g.
> general.all_logs no longer exists as all syslog data is now captured in the
> 'logs' plugin (there is a corresponding logs.all_logs option now).


plus...

(In reply to Bryn M. Reeves from comment #10)
> In reply to comment #8 - it's not really clear what's happening here.
> Clearly engine-log-collector got something it didn't expect in the output
> from the remote sos command but without seeing what the output was it's hard
> to say what may have caused it.
> 
> Note that there's been some reorganisation of plugins in 3.0 - e.g.
> general.all_logs no longer exists as all syslog data is now captured in the
> 'logs' plugin (there is a corresponding logs.all_logs option now).

(In reply to Bryn M. Reeves from comment #12)
> OK looking at the output in the attachment:
> 
> https://bugzilla.redhat.com/attachment.cgi?id=886516
> 
> It seems to be the problem I suggested in comment #10 - the "all_logs"
> option has moved from the general plugin to the logs plugin:
> 
> DEBUG: returncode(0)
> DEBUG: STDOUT(
> sosreport (version 3.0)
> 
> )
> DEBUG: STDERR(Error reading response length from authentication socket.
> 
> no such option "all_logs" for plugin (general)
> )
> 
> It might be useful to teach the log collector some of the common errors
> sosreport can spit out so that it can react to this better.

Version-Release number of selected component (if applicable):
vdsm3-4.14.6-0.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. rhel7 host in RHEVM 3.4 env (vdsm and dependencies from brew)
2. run engine-log-collector
3.

Actual results:
no data from host

Expected results:
*.xz archive with host's data

Additional info:
see BZ1060383 for relevant info

Comment 1 Sandro Bonazzola 2014-04-16 14:45:45 UTC
Thanks for reporting, all_logs collection was disabled on upstream master for sos >= 3.0 because it failed on general.all_logs missing.
Now it's enabled again adding the logs plugin and logs.all_logs=True if sos >= 3.0

Comment 2 Sandro Bonazzola 2014-05-14 13:30:59 UTC
merged on upstream master for 3.5.0 rebase

Comment 3 Jiri Belka 2014-05-21 12:14:51 UTC
Please clarify version to be used for verification. FYA, the product is RHEVM, but 'Fixed in Version' is ovirt.

Comment 4 Sandro Bonazzola 2014-05-21 13:48:49 UTC
(In reply to Jiri Belka from comment #3)
> Please clarify version to be used for verification. FYA, the product is
> RHEVM, but 'Fixed in Version' is ovirt.

Since we're still in early rhev 3.5.0 development, upstream ovirt 3.5.0 alpha rpms can be used for verification.

Comment 6 Jiri Belka 2014-05-23 07:53:13 UTC
ok, ovirt-3.5-pre with rhel7 host in 3.4 cl level.

Comment 8 errata-xmlrpc 2015-02-11 17:45:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0193.html


Note You need to log in before you can comment on or make changes to this bug.