Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1087794 - Move /etc/rpm/macros.ocaml-srpm from redhat-rpm-config to ocaml-srpm-macros
Summary: Move /etc/rpm/macros.ocaml-srpm from redhat-rpm-config to ocaml-srpm-macros
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1087893
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker 1085341
TreeView+ depends on / blocked
 
Reported: 2014-04-15 10:22 UTC by Richard W.M. Jones
Modified: 2014-04-22 10:20 UTC (History)
5 users (show)

Fixed In Version: ocaml-4.01.0-16.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of: 1085341
Environment:
Last Closed: 2014-04-22 10:20:39 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-04-15 10:22:48 UTC
RWMJ wrote:

In general terms (not related to ppc64le) I wish that
RPM would *not* have an ocaml_arches macro at all.

The macro usually has the wrong contents, but more seriously
it is incorrect: There are two separate sets of OCaml native
arches, those supporting compilation and those supporting
native dynamic linking.  We could define the correct macro(s)
in the OCaml package.

--- Additional comment from Panu Matilainen on 2014-04-15 05:05:45 EDT ---

These macros are not my invention, its nothing but ridiculous (not to mention cumbersome to all involved parties) that I'm the "maintainer" of these macros when I haven't got a clue. Gnat? Is that a sound caused by swallowing with a dry throat? Although I suppose it means something different here...

The reason these macros are in redhat-rpm-config is a compromise because they need to be present on the buildsystem at .src.rpm creation time (ie before buildrequires have been evaluated) and you dont want to pull in every possible language stack into the buildsys "just because".

Now, perl already has its own "perl-srpm-macros" package which redhat-rpm-config requires for the above reason, this arrangement transfers the language stack control and knowledge out of my lap to where it belongs. So if you Richard want a similar arrangement for OCaml, I'm game. Just be careful not to add excess dependencies to the ocaml-srpm-macros package because that'll get pulled in on a LOT of systems.

   --- --- --- --- --- ---

Let's do three things:

(1) Add /etc/rpm/macros.ocaml-srpm with the correct content to
a new subpackage called ocaml-srpm-macros

(2) Remove /etc/rpm/macros.ocaml-srpm from redhat-rpm-config

(3) Add Require: ocaml-srpm-macros to redhat-rpm-config.spec

(Note: This is for Rawhide only)

Comment 1 Richard W.M. Jones 2014-04-15 10:56:38 UTC
(In reply to Richard W.M. Jones from comment #0)
> (1) Add /etc/rpm/macros.ocaml-srpm with the correct content to
> a new subpackage called ocaml-srpm-macros

This is now done in the OCaml package, building here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=6740174

Since this package will conflict with the redhat-rpm-config
package, I can't fix the other problem packages until
redhat-rpm-config drops the file.

Comment 3 Panu Matilainen 2014-04-15 13:53:05 UTC
Hmph. We actually just introduced a bit of a bootstrap problem: redhat-rpm-config is required to build anything at all in Fedora, so being able to build anything at all now requires building OCaml first.

Would be better if ocaml-srpm-macros were a standalone package rather than a sub-package of ocaml itself (iirc that's how the perl-counterpart is done)

Comment 4 Richard W.M. Jones 2014-04-15 14:01:16 UTC
OK, we can do this.

Comment 5 Richard W.M. Jones 2014-04-15 14:19:42 UTC
Please help by reviewing this extremely simple package!
https://bugzilla.redhat.com/show_bug.cgi?id=1087893

Comment 6 Richard W.M. Jones 2014-04-22 10:20:39 UTC
This build of OCaml (ocaml-4.01.0-16.fc21) removes the
ocaml-srpm-macros subpackage, because it is now replaced
by a separate ocaml-srpm-macros real package in Rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6764118


Note You need to log in before you can comment on or make changes to this bug.