Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1087343 - Disable "next" button in storage volumes page if the disk space is less then the minimum size(1295M)
Summary: Disable "next" button in storage volumes page if the disk space is less then ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1087324
Blocks: 1118297 1120060 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-14 08:57 UTC by cshao
Modified: 2016-02-10 20:10 UTC (History)
19 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.13
Doc Type: Bug Fix
Doc Text:
Clone Of: 1087324
: 1120060 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:55:36 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
disk space (deleted)
2014-04-14 08:57 UTC, cshao
no flags Details
expection (deleted)
2014-04-14 08:59 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 26862 None None None Never

Description cshao 2014-04-14 08:57:58 UTC
Created attachment 886069 [details]
disk space

+++ This bug was initially created as a clone of Bug #1087324 +++

Description of problem:
In current build, the minimum required size of storage volumes are 1295M (UEFI:256 + Root & RootBackup: 512*2 + Swap:5 + Config:5 + Logging:5 + Data:0)

But if install the ovirt-node-iso to a small disk which size is less then 1295M(e.g. 100M), the installation will fail.

So disable "next" button in storage volumes page if the disk space is less then the minimum size(1295M) can avoid this issue.

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.4-20140410.0.el6.iso

How reproducible:
100%

Steps to Reproduce:
1. Prepare a small size disk(e.g. 100M)
2. Install ovirt-node-iso to above disk.
3. Focus on storage volumes page.

Actual results:
Exception occurs: RuntimeError('Failed to partition/format',)

Expected results:
1. Disable "next" button in storage volumes page if the disk space is less then the minimum size(1295M)
2. Pop-up a warning info for user and stop the installation process.

Additional info:

Comment 1 cshao 2014-04-14 08:59:07 UTC
Created attachment 886070 [details]
expection

Comment 2 cshao 2014-04-14 09:00:34 UTC
The same issue occurs on downstream build rhevh-6.5-20140317.0, so clone to here.

Comment 5 cshao 2014-12-12 04:47:17 UTC
Test version:
rhevh-7.0-20141119.0.el7ev.iso
ovirt-node-3.1.0-0.27.20141119git24e087e.el7.noarch

rhev-hypervisor6-6.6-20141119.0.iso
ovirt-node-3.1.0-0.27.20141119git24e087e.el6.noarch

Test steps:
1. Prepare a small size disk(e.g. 100M)
2. Install ovirt-node-iso to above disk.
3. Focus on storage volumes page.

Test result:
1. Can't continue the installation.
2. Pop-up info "Not enough space! Need at least 1295MB for installation, 100MB abailable"

So the bug was fixed by above builds, change bug status to VERIFIED.

Comment 7 errata-xmlrpc 2015-02-11 20:55:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.