Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1086259 - [webadmin] when creating new VM the nic1 lable is greyed out.
Summary: [webadmin] when creating new VM the nic1 lable is greyed out.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-10 13:25 UTC by Kobi Hakimi
Modified: 2016-02-10 19:58 UTC (History)
12 users (show)

Fixed In Version: vt2.2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:11:43 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)
snapshot of the greyed out nic1 (deleted)
2014-04-10 13:25 UTC, Kobi Hakimi
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 31879 master MERGED webadmin: TypeAheadListBox to display default text Never
oVirt gerrit 31880 master MERGED webadmin: Fix vNIC widget behavior Never
oVirt gerrit 31890 ovirt-engine-3.5 MERGED webadmin: TypeAheadListBox to display default text Never
oVirt gerrit 31891 ovirt-engine-3.5 MERGED webadmin: Fix vNIC widget behavior Never

Description Kobi Hakimi 2014-04-10 13:25:34 UTC
Created attachment 884949 [details]
snapshot of the greyed out nic1

Description of problem:
when creating new VM, in the first screen the nic1 lable is greyed out.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.4.0-0.13.beta3.el6ev 

How reproducible:

Steps to Reproduce:
1.Press on "New VM" from the "Virtual Machines" tab in the admin portal. 
2.At the bottom on the New VM wizard you can see the :
  "VM has no network interfaces. To add one, assign a profile" .
  and the "nic1" lable.

Actual results:
The nic1 lable for this option is confusing. 
cause its greyed out as it is "undefinable" at this stage. 
It should be black as all other optional fields.


Expected results:


Additional info:
As new worker I tried to turn the nic1 on by click on the check boxes above it.
IMHO when you can use this field without any checkbox(enable\disable) its should be black(enable).

Comment 1 Kobi Hakimi 2014-04-10 13:32:16 UTC
Its kind of continuous bug of Bug # 1064431 - [webadmin] UI is confusing for defining a network connection to a vm

Comment 2 Lior Vernia 2014-04-10 13:54:32 UTC
It is by purpose, when no profile is assigned the vNIC will not be created upon approval of the dialog - the grayness is supposed to signify that the vNIC is not instantiated. I think this is not a bug, but I don't mind to hear UX people weigh in.

Comment 3 Lior Vernia 2014-06-12 08:01:10 UTC
Malini, care to voice your opinion?

Comment 4 mrao 2014-06-23 21:14:58 UTC
(In reply to Lior Vernia from comment #3)
> Malini, care to voice your opinion?

Lior, I understand your point about conveying to the user that the vNIC is not instantiated until a profile is associated but the fact that the label is grayed out makes it seem like the profile cannot be associated. I did read the instructional text above the field that states that I need to associate a profile to add the nic but I didn't see this text at first and it is not uncommon for the user to gloss over text on the screen. Even with this text, the grayed label throws the user off - it is a strong learning that if a field label is grayed out, nothing can be done with it. 

Having said that, I think we may need to just add the hint text within the drop down such as - "Select Network Profile'. This is necessary anyway since otherwise it is not clear what you are selecting unless you read the instructional text above. If atleast one vNIC is mandatory and the user does not select a profile and tries to commit the dialog, an error should display stating a vNIC can be added only when a profile is associated. If not, then I think it is fine as it is as no vNIC will take effect without a profile.

Alternately, we can just have a label called 'vNIC' and a + button. Clicking the +button should give you a Name and Profile inline dialog with a ok button and then that vNIC gets added. I am suggesting this only because you are trying to avoid a commit button but trying to make up with the gray label which is potentially confusing.

Comment 5 Lior Vernia 2014-08-25 05:46:20 UTC
Added a gray text inside the list box asking the user to select an item - hopefully that should be enough.

Comment 6 Martin Pavlik 2014-09-08 14:05:42 UTC
verified on vt2.2

Comment 7 Eyal Edri 2015-02-17 17:11:43 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.