Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1086244 - [User Portal] Windows VNC-based VM are opened via RDP by default in User Portal
Summary: [User Portal] Windows VNC-based VM are opened via RDP by default in User Portal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Frantisek Kobzik
QA Contact: Jiri Belka
URL:
Whiteboard: virt
Depends On:
Blocks: 1108673 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-10 12:55 UTC by Jiri Belka
Modified: 2015-02-17 08:27 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1108673 (view as bug list)
Environment:
Last Closed: 2015-02-17 08:27:31 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27133 master MERGED frontend: console protocol priority Never
oVirt gerrit 27462 ovirt-engine-3.4 MERGED frontend: console protocol priority Never
oVirt gerrit 27579 master MERGED frontend: Console PriorityComparator should be serializable Never
oVirt gerrit 27608 master MERGED frontend: serialVersionUID for console priority comparator Never

Description Jiri Belka 2014-04-10 12:55:05 UTC
Description of problem:
When a Windows VM has VNC as display protocol, console and/or console options is opened/reveals that RDP is used. 

Tested on:
- client RHEL 6.5
- Windows VM Win 7 64bit
- FF

Version-Release number of selected component (if applicable):
av6.1 - rhevm-userportal-3.4.0-0.13.beta3.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. have clean cache in FF
2. run a Windows VM (win7 64bit) with either default VNC display proto (vm properties) or via Run Once dialog
3. check Console Options for what is selected, click Cancel; open console

Actual results:
3. - RDP, RDP mime file - console.rdp is offered for download

Expected results:
vnc, vnc

Additional info:
please make vnc as default, rdp needs working networking inside guest VM and by default resolvable VM name via dns. vnc does not need working networking inside guest OS as it is just redisplaying primary console of emulated console of qemu-kvm process. ok? :)

Comment 1 Jiri Belka 2014-04-11 10:14:52 UTC
I just discovered that if VM is Windows 8 I can't change RDP to VNC manually via Console options dialog, thus I'm unable to get Windows 8 console on non-Windows client desktop.

Comment 2 Jiri Belka 2014-04-11 10:25:13 UTC
Changing to urgent because of comment#1 and it is regression because one could open Windows 8/2012 console in the past.

Comment 5 Jiri Belka 2014-07-31 10:15:24 UTC
ok, ovirt-engine-userportal-3.5.0-0.0.master.20140722232058.git8e1babc.el6.noarch

Comment 7 Omer Frenkel 2015-02-17 08:27:31 UTC
RHEV-M 3.5.0 has been released


Note You need to log in before you can comment on or make changes to this bug.