Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1086003 - [RHEVM-SETUP] - reports upgrade failes during jasper deployment [NEEDINFO]
Summary: [RHEVM-SETUP] - reports upgrade failes during jasper deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.4.0
Assignee: Shirly Radco
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks: 1071020 1077775 rhev3.4rc 1121792
TreeView+ depends on / blocked
 
Reported: 2014-04-09 20:48 UTC by Barak Dagan
Modified: 2014-08-21 08:07 UTC (History)
14 users (show)

Fixed In Version: av8 - rhevm-reports-3.4.0-7.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, attempting to upgrade from Red Hat Enterprise Virtualization 3.3 to Red Hat Enterprise Virtualization 3.4 would fail under certain conditions. This was caused by an issue in allowing an older version of JasperReports to be used. Now, the version of JasperReports required by Red Hat Enterprise Virtualization has been increased to 5.5.0-7, making it possible to complete the upgrade process correctly.
Clone Of:
: 1121792 (view as bug list)
Environment:
Last Closed: 2014-08-21 08:07:00 UTC
oVirt Team: ---
Target Upstream Version:
ylavi: needinfo? (wliu)


Attachments (Terms of Use)
setup log (deleted)
2014-04-09 20:48 UTC, Barak Dagan
no flags Details
ovirt-setup log (deleted)
2014-08-21 07:24 UTC, liuwei
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0602 normal SHIPPED_LIVE rhevm-reports 3.4 bug fix and enhancement update 2014-06-09 19:26:10 UTC
oVirt gerrit 27117 master MERGED packaging: build: require newer jasperreports Never

Description Barak Dagan 2014-04-09 20:48:12 UTC
Created attachment 884646 [details]
setup log

Description of problem:
During updagrade from clean 3.3.2 to av6.1, the setup fails:

[ INFO  ] Creating/refreshing DWH database schema
[ INFO  ] Regenerating Jasper's build configuration files
[ INFO  ] Exporting data out of Jasper
[ INFO  ] Backing up database *:rhevmreports to '/var/lib/ovirt-engine-reports/backups/reports-20140410020529.dMFuN6.sql'.
[ INFO  ] Deploying Jasper
[ ERROR ] Failed to execute stage 'Misc configuration': Command './js-ant' failed to execute                                                                                                                            
[ INFO  ] Yum Performing yum transaction rollback

log:

2014-04-10 02:25:20 ERROR otopi.context context._executeMethod:161 Failed to execute stage 'Misc configuration': Command './js-ant' failed to execute
2014-04-10 02:25:20 DEBUG otopi.transaction transaction.abort:131 aborting 'Yum Transaction'
2014-04-10 02:25:20 INFO otopi.plugins.otopi.packagers.yumpackager yumpackager.info:92 Yum Performing yum transaction rollback
Loaded plugins: product-id, rhnplugin, versionlock


Version-Release number of selected component (if applicable):
av6.1

How reproducible:
100%

Steps to Reproduce:
1. Install 3.3.2 engine + dwh + reports
2. Add DC + .. 5 running VMs
3. Add SSO users.
4. Upgarde engine + dwh to 3.4.0 (yum + setup)
5. Update reports to 3.4.0 (yum + setup)

Actual results:
Installation fails

Expected results:


Additional info:

Comment 1 Yedidyah Bar David 2014-04-22 08:31:22 UTC
(In reply to Barak Dagan from comment #0)
> Created attachment 884646 [details]
> setup log
> 
> Description of problem:
> During updagrade from clean 3.3.2 to av6.1, the setup fails:
> 
> [ INFO  ] Creating/refreshing DWH database schema
> [ INFO  ] Regenerating Jasper's build configuration files
> [ INFO  ] Exporting data out of Jasper
> [ INFO  ] Backing up database *:rhevmreports to
> '/var/lib/ovirt-engine-reports/backups/reports-20140410020529.dMFuN6.sql'.
> [ INFO  ] Deploying Jasper
> [ ERROR ] Failed to execute stage 'Misc configuration': Command './js-ant'
> failed to execute                                                           
> 

The error is:

execute-output: ('./js-ant', '-DmasterPropsSource=/tmp/tmp9npIPO/config', 'deploy-webapp-pro') stderr:

BUILD FAILED
/usr/share/jasperreports-server-pro/buildomatic/bin/app-server.xml:833: Warning: Could not find file /var/lib/install_resources/jboss7/jboss-deployment-structure.xml to copy.

I also stumbled upon this during verifying http://gerrit.ovirt.org/26005 and http://gerrit.ovirt.org/25998 but did not manage to reproduce. Also consulted Yaniv trying to figure out why it tries to access /var/lib/install_resources and we did not mange to find a reason for this.

Please try to reproduce under strace, hopefully it will give us a clue. Something like:

strace -f -o /tmp/strace-setup.log -tt -s 0 /usr/bin/engine-setup

Thanks!

Comment 2 Barak Dagan 2014-04-23 08:51:32 UTC
Logs are too large to upload, sending them offline

Comment 3 Yedidyah Bar David 2014-04-23 20:56:20 UTC
(Following lots of tests by Barak, some more searches etc., consulting Alon)

Seems like it's just a recent fix to jasper [1]

On a system with jasperreports-server-pro-5.5.0-9.el6ev.noarch, I have the file /usr/share/jasperreports-server-pro/buildomatic/bin/app-server.xml patched to do:

                            <equals arg1="${app-server_AppServer}" arg2="jboss_EAP6orAS7" />
                            <then>
                                <copy file="${basedir}/install_resources/jboss7/jboss-deployment-structure.xml" toDir="${warTargetDir}/META-INF" overwrite="true"/>
                                <copy file="${currentConf}/js-jboss7-ds.xml" toDir="${warTargetDir}/WEB-INF" overwrite="true"/>
                                <touch file="${jbossDeployDir}/${webAppName}.war.dodeploy"/>
                            </then>

But on the test system of Barak, with jasperreports-server-pro-5.5.0-6.el6ev.noarch, it has:

                            <equals arg1="${app-server_AppServer}" arg2="jboss_EAP6orAS7" />
                            <then>
                                <copy file="${currentConf}/../../install_resources/jboss7/jboss-deployment-structure.xml" toDir="${warTargetDir}/META-INF" overwrite="true"/>
                                <copy file="${currentConf}/js-jboss7-ds.xml" toDir="${warTargetDir}/WEB-INF" overwrite="true"/>
                                <touch file="${jbossDeployDir}/${webAppName}.war.dodeploy"/>
                            </then>

[1] http://gerrit.ovirt.org/23303

Barak - please try again from scratch with an updated jasper reports package.

If it works for you, we should probably change the Require line to use a recent version. We currently require >= 5.5.0-6 .

Comment 4 Barak 2014-04-24 12:37:03 UTC
Yaniv if this is the case -  who should change the require >= 5.5.0-6 dependency

Comment 5 Yedidyah Bar David 2014-04-24 12:49:58 UTC
(In reply to Barak from comment #4)
> Yaniv if this is the case -  who should change the require >= 5.5.0-6
> dependency

I do, Yaniv can too - it's a trivial fix. Is it?

Comment 6 Barak Dagan 2014-04-24 14:28:51 UTC
upgrading jasperreports-server-pro from 5.5.0-6.el6ev to 5.5.0-9.el6ev beforehand does solve the issue.

Please update the dependency.

Comment 8 Barak Dagan 2014-05-01 14:19:26 UTC
Verified on av8.1 upgraded from is35:

[ INFO  ] Yum Status: Downloading Packages
[ INFO  ] Yum Download/Verify: jasperreports-server-pro-5.5.0-9.el6ev.noarch
[ INFO  ] Yum Download/Verify: patch-2.6-6.el6.x86_64
[ INFO  ] Yum Download/Verify: rhevm-dwh-3.4.0-8.el6ev.noarch
[ INFO  ] Yum Download/Verify: rhevm-reports-3.4.0-7.el6ev.noarch
[ INFO  ] Yum Status: Check Package Signatures
[ INFO  ] Yum Status: Running Test Transaction
[ INFO  ] Yum Status: Running Transaction
[ INFO  ] Yum update: 1/7: jasperreports-server-pro-5.5.0-9.el6ev.noarch
[ INFO  ] Yum install: 2/7: patch-2.6-6.el6.x86_64
[ INFO  ] Yum update: 3/7: rhevm-reports-3.4.0-7.el6ev.noarch
[ INFO  ] Yum update: 4/7: rhevm-dwh-3.4.0-8.el6ev.noarch
[ INFO  ] Yum updated: 5/7: rhevm-reports
[ INFO  ] Yum updated: 6/7: jasperreports-server-pro
[ INFO  ] Yum updated: 7/7: rhevm-dwh
[ INFO  ] Yum Verify: 1/7: rhevm-dwh.noarch 0:3.4.0-8.el6ev - u
[ INFO  ] Yum Verify: 2/7: patch.x86_64 0:2.6-6.el6 - u
[ INFO  ] Yum Verify: 3/7: rhevm-reports.noarch 0:3.4.0-7.el6ev - u
[ INFO  ] Yum Verify: 4/7: jasperreports-server-pro.noarch 0:5.5.0-9.el6ev - u
[ INFO  ] Yum Verify: 5/7: rhevm-dwh.noarch 0:3.3.2-1.el6ev - ud
[ INFO  ] Yum Verify: 6/7: rhevm-reports.noarch 0:3.3.2-3.el6ev - ud
[ INFO  ] Yum Verify: 7/7: jasperreports-server-pro.noarch 0:5.5.0-6.el6ev - ud

Comment 9 errata-xmlrpc 2014-06-09 15:28:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0602.html

Comment 12 liuwei 2014-08-21 00:23:07 UTC
Created attachment 928980 [details]
engine-setup log

The log for the bug

Comment 14 Shirly Radco 2014-08-21 06:16:47 UTC
Hi, 

You didn't attach the correct logs.

Shirly

Comment 16 Shirly Radco 2014-08-21 07:13:10 UTC
The log is located at /var/log/ovirt-engine/setup/

Shirly

Comment 17 liuwei 2014-08-21 07:24:20 UTC
Created attachment 929079 [details]
ovirt-setup log

Comment 18 liuwei 2014-08-21 07:25:18 UTC
(In reply to liuwei from comment #17)
> Created attachment 929079 [details]
> ovirt-setup log

I had uploaded it

Comment 19 Yaniv Lavi 2014-08-21 08:07:00 UTC
This happened because the host name wasn't fully resolvable like required.
Please correct this.



Yaniv


Note You need to log in before you can comment on or make changes to this bug.