Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1085850 - ocaml-camlp5 do not build with ocaml native compiler on ppc64le archi
Summary: ocaml-camlp5 do not build with ocaml native compiler on ppc64le archi
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml-camlp5
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Michel Normand
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1077767
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-04-09 13:54 UTC by Michel Normand
Modified: 2014-04-10 12:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-10 12:41:27 UTC


Attachments (Terms of Use)
ocaml-camlp5.spec.ppc64le.patch (deleted)
2014-04-09 14:05 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-04-09 13:54:01 UTC
Description of problem: ocaml-camlp5 do not build with ocaml native compiler on ppc64le archi

Version-Release number of selected component (if applicable):
ocaml-camlp5-6.11-1.fc21

Steps to Reproduce:
1. fedpkg clone -a ocaml-camlp5
2. fedpkg prep
3. fedpkg mockbuild

Actual results:
===
make[2]: Entering directory `/builddir/build/BUILD/camlp5-6.11/meta'
ocamlrun ../boot/camlp5r -nolib -I ../boot -mode S -o q_MLast.ppo q_MLast.ml
ocamlopt.opt -g -warn-error A -I ../main -I ../boot -I ../ocaml_stuff/4.01.0/utils -c -impl q_MLast.ppo
../tools/ocamlopt.sh: line 5: 31034 Segmentation fault      $COMM $*
make[2]: *** [q_MLast.cmx] Error 139
make[2]: Leaving directory `/builddir/build/BUILD/camlp5-6.11/meta'
===

Comment 1 Michel Normand 2014-04-09 14:05:48 UTC
Created attachment 884510 [details]
ocaml-camlp5.spec.ppc64le.patch

ocaml-camlp5.spec.ppc64le.patch is the solution to the reported build failure.
As reported in the patch need only to increase stack size in spec file before make operation.

Comment 2 Michel Normand 2014-04-10 11:54:52 UTC
patch committed in ocaml-camlp5-6.11-2

Comment 3 Richard W.M. Jones 2014-04-10 12:04:09 UTC
Since this is Rawhide, you can just close this bug (CLOSED->RAWHIDE)
as soon as there is a build in ppc-koji.


Note You need to log in before you can comment on or make changes to this bug.