Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1085820 - Date range in some reports queries is incorrect - includes the end date
Summary: Date range in some reports queries is incorrect - includes the end date
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard: infra
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-09 12:50 UTC by Shirly Radco
Modified: 2016-02-10 19:08 UTC (History)
9 users (show)

Fixed In Version: vt10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 18:17:13 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC
oVirt gerrit 27711 master MERGED reports: Fixed date range in reports queries Never

Description Shirly Radco 2014-04-09 12:50:59 UTC
Description of problem:

Date range in some reports queries is incorrect - includes the end date.
The date range should be from the starts date (included)
till the end date (excluded).


Version-Release number of selected component (if applicable):


How reproducible:


Example query report currently:

AND history_datetime >= CAST ( $P{P_Start_Date} AS TIMESTAMP )
AND history_datetime <=
	        CASE ..

Should be:

AND history_datetime >= CAST ( $P{P_Start_Date} AS TIMESTAMP )
AND history_datetime <
	        CASE ..



Actual results:

The date range is from the starts date (included)
till the end date (included).

Expected results:

The date range should be from the starts date (included)
till the end date (excluded).

Additional info:
Report for example: br46

Comment 1 Shirly Radco 2014-05-26 08:23:37 UTC
Reports fixed in this bug:

BR18, BR19, BR17, BR7, BR8, BR13, BR46, BR16, BR10A, BR22B, BR22B, BR18A, BR23, BR6B, BR4, BR11, BR7A, BR14A

Comment 4 errata-xmlrpc 2015-02-11 18:17:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.