Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1084915 - [Network Label] Cannot break bond with Network label attached by break bond action
Summary: [Network Label] Cannot break bond with Network label attached by break bond a...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: GenadiC
URL:
Whiteboard: network
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-07 08:43 UTC by GenadiC
Modified: 2016-02-10 19:57 UTC (History)
11 users (show)

Fixed In Version: vt1.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:09:11 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26889 master MERGED engine: Don't resurrect removed bonds for label Never
oVirt gerrit 27029 ovirt-engine-3.4 MERGED engine: Don't resurrect removed bonds for label Never

Description GenadiC 2014-04-07 08:43:02 UTC
Description of problem:

setupNetwork action fails when you try to break bond with network attached to it using network labels.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create network with label xxx
2. Create bond and attach to it label xxx - (as a result network is attached to bond)
3. Try to break bond

Actual results:You get an error message: "Cannot setup Networks. The following networks cannot be removed from the network interface since they are managed by the label: <net-name>. Please remove the label from the network interface in order to remove the network."


Expected results:
Bond should disappear and no label should appear on any slave interface

Additional info:

Comment 1 Nir Yechiel 2014-04-09 11:27:42 UTC

*** This bug has been marked as a duplicate of bug 1084771 ***

Comment 2 GenadiC 2014-07-16 14:03:49 UTC
Verified in ovirt-engine-3.5.0-0.0.master.20140715172116.git4687dc1.el6.noarch

Comment 3 Eyal Edri 2015-02-17 17:09:11 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.