Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1083540 - pth add ppc64le support
Summary: pth add ppc64le support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pth
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Michael Schwendt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-04-02 12:17 UTC by Menanteau Guy
Modified: 2014-04-03 20:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-03 20:55:28 UTC


Attachments (Terms of Use)
add ppc64le support (deleted)
2014-04-02 12:17 UTC, Menanteau Guy
no flags Details

Description Menanteau Guy 2014-04-02 12:17:41 UTC
Created attachment 881756 [details]
add ppc64le support

build pth with ppc64le arch is not yet supported

Version-Release number of selected component (if applicable):
pth-2.0.7-21.fc21.ppc64le

How reproducible:
rpmbuild --target ppc64le

Additional info:
In order to build successfully pth on arch ppc64le I patched config.guess and pth-config.in.
Note that on this version of pth, my patches need to be run after the existing pth-2.0.7-config-script.patch.

Please, consider that I did not test it at run-time.

Comment 1 Michael Schwendt 2014-04-02 20:32:12 UTC
Please give more background about the first half of the patch. Why is it still necessary, if /usr/lib/rpm/redhat/config.guess knows about ppc64le? Examine "rpm -E %configure".

Comment 2 Menanteau Guy 2014-04-03 09:58:09 UTC
The only patch needed to have pth built (including make check) is the one relative to pth-config.in.
Patch of config.guess is not necessary for pth package but because it was necessary for some packages I worked on, I add it in a systematic manner when I build for ppc64le arch.

Comment 3 Michael Schwendt 2014-04-03 20:55:28 UTC
Okay. Thanks!


Note You need to log in before you can comment on or make changes to this bug.