Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1083429 - gmp ppc64le support
Summary: gmp ppc64le support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gmp
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Frantisek Kluknavsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-04-02 08:54 UTC by Menanteau Guy
Modified: 2014-07-10 16:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-10 16:24:26 UTC


Attachments (Terms of Use)
gmp headers patches (deleted)
2014-04-03 15:53 UTC, Menanteau Guy
no flags Details | Diff
gmp patch for ppc64le (deleted)
2014-04-15 15:32 UTC, Brent Baude
no flags Details | Diff
trivial patch for ppc64le and gmp-6, already upstream (deleted)
2014-04-15 15:35 UTC, Brent Baude
no flags Details | Diff
gmp-6-ppc64le-enable.v2.patch (deleted)
2014-07-10 09:58 UTC, Michel Normand
no flags Details | Diff

Description Menanteau Guy 2014-04-02 08:54:57 UTC
Description of problem:
build failed with ppc64le arch

Version-Release number of selected component (if applicable):
gmp-5.1.3.2.fc21.ppc64le

How reproducible:
rpmbuild --target ppc64le

Actual results:
/bin/ld: mpn/.libs/add_n.o: ABI version 1 is not compatible with ABI version 2 output
/bin/ld: failed to merge target specific data of file mpn/.libs/add_n.o
/bin/ld: mpn/.libs/sub_n.o: ABI version 1 is not compatible with ABI version 2 output

Additional info:
ppc64le must run in abiv2 and gmp needs patches to support it.

I got following ppc64le patches from suse:
gmp-support-powerpc64le-linux.patch
gmp-ppc64le-mod.patch

https://build.opensuse.org/package/show/openSUSE:Factory:PowerPC/gmp
note that I did not find a relative upstream bug.

Comment 1 Menanteau Guy 2014-04-03 15:53:12 UTC
Created attachment 882366 [details]
gmp headers patches

This patch is not to be added in the gmp.spec file as gmp.h and gmp-mparam.h are not embedded in the gmp-5.1.3.tar.bz2 file.

Comment 2 Menanteau Guy 2014-04-03 15:55:29 UTC
(This comments is relative to comment1)

I have got errors about gmp when I built php package for ppc64le arch.

Actual results:
In file included from /builddir/build/BUILD/php-5.5.11/ext/gmp/php_gmp.h:24:0,
                 from /builddir/build/BUILD/php-5.5.11/ext/gmp/gmp.c:25:
/usr/include/gmp.h:43:23: fatal error: gmp-ppc64.h: No such file or directory
 #include "gmp-ppc64.h"
                       ^
compilation terminated.

This is because I missed some patches for ppc64le arch on gmp.h and gmp-mparam.h headers in the gmp package that make /usr/include/gmp/gmp* files not correct.
Please consider gmp-ppc64le-header.patch attached file.

Comment 3 Brent Baude 2014-04-15 15:32:30 UTC
Created attachment 886530 [details]
gmp patch for ppc64le

Comment 4 Brent Baude 2014-04-15 15:35:21 UTC
Created attachment 886531 [details]
trivial patch for ppc64le and gmp-6, already upstream

Comment 5 Brent Baude 2014-04-15 15:37:08 UTC
Note with gmp-6, we only need changes to the header files and a trivial, already upstream (https://gmplib.org/repo/gmp/rev/4a6d258b467f) patch added to the spec.  I've included the upstream patch and changes needed to the headers and spec

Also, you can see that the changes built fine on the ppcle koji at -> http://ppc-le.koji.fedoraproject.org/koji/taskinfo?taskID=4538

Comment 6 Michel Normand 2014-06-26 12:39:16 UTC
Hi Frantisek,
Is there a target date to have the above patches integrated in fedora ?
This bug make the botan and softhsm packages to fail
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1901668
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1901983

Comment 7 Michel Normand 2014-07-10 09:46:00 UTC
Comment on attachment 886531 [details]
trivial patch for ppc64le and gmp-6, already upstream

this patch has been committed in fedora db: http://pkgs.fedoraproject.org/cgit/gmp.git/commit/?id=296a7a71b43e74be561d0f5a5ee69e02e1c903c9

Comment 8 Michel Normand 2014-07-10 09:58:50 UTC
Created attachment 917034 [details]
gmp-6-ppc64le-enable.v2.patch

update the previous gmp-6-ppc64le-enable.patch as gmp-6-ppc64le-enable.v2.patch because gmp.spec has been changed in the meantime.

patch to be applied in fedora gdm tree:
===
fedpkg clone gmp
cd gmp
git apply gmp-6-ppc64le-enable.v2.patch
===

Comment 9 Michel Normand 2014-07-10 10:16:29 UTC
(In reply to Michel Normand from comment #6)
> Hi Frantisek,
> Is there a target date to have the above patches integrated in fedora ?
> This bug make the botan and softhsm packages to fail
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1901668
> http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1901983

another package that failed for same reason is seed:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=1939426

Comment 10 Michel Normand 2014-07-10 16:24:26 UTC
(In reply to Michel Normand from comment #8)
> Created attachment 917034 [details]
> gmp-6-ppc64le-enable.v2.patch

committed in fedora db as http://pkgs.fedoraproject.org/cgit/gmp.git/commit/?h=f21&id=e271a2d08aad23079e12499014c350650a2f2abf


Note You need to log in before you can comment on or make changes to this bug.