Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1083401 - RHEV-H option disable IPv6 does not work
Summary: RHEV-H option disable IPv6 does not work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.6.0
Assignee: Anatoly Litovsky
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: rebase-ovirt-node-3.1
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-02 07:41 UTC by Martin Pavlik
Modified: 2016-02-10 20:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-09-17 15:32:09 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
interface_configuration_dialog (deleted)
2014-04-02 07:41 UTC, Martin Pavlik
no flags Details
TUI after choosing disable ipv6 (deleted)
2014-04-02 07:42 UTC, Martin Pavlik
no flags Details
ifconfig_output (deleted)
2014-12-18 06:14 UTC, Yaning Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27952 master MERGED disable ipv6 when option is set to disabled Never

Description Martin Pavlik 2014-04-02 07:41:31 UTC
Created attachment 881656 [details]
interface_configuration_dialog

Description of problem:
If user picks to disable IPv6 in TUI NIC configuration dialog IPv6 does not get disabled (see screenshots)

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140320.0.el6ev)

How reproducible:
100%

Steps to Reproduce:
1. install RHEV-H (do not add to RHEV-M so you can manage NICs via TUI)
2. Network -> em1 -> enter -> ok
3. IPv4 settings -> DHCP
4. IPv6 settings -> Disabled (in order to see the problem you will need dhcp which assigns also IPv6 addresses)

Actual results:
If user picks to disable IPv6 in TUI NIC configuration dialog IPv6 does not get disabled (see screenshots)for the particular interface

Expected results:
If user picks to disable IPv6 in TUI NIC configuration dialog IPv6 is disabled for the particular interface

Additional info:

adding
“IPV6INIT=no”
“IPV6_AUTOCONF=no”
into ifcfg file/s should solve the issue

network configuration after picking disable IPv6

[root@dell-r210ii-06 ~]# cat /etc/sysconfig/network-scripts/ifcfg-em1 
BOOTPROTO="dhcp"
DEVICE="em1"
HWADDR="d0:67:e5:f0:83:5e"
ONBOOT="yes"
PEERNTP="yes"

[root@dell-r210ii-06 ~]# ifconfig em1
em1       Link encap:Ethernet  HWaddr D0:67:E5:F0:83:5E  
          inet addr:10.34.66.61  Bcast:10.34.66.255  Mask:255.255.255.0
          inet6 addr: 2620:52:0:2242:d267:e5ff:fef0:835e/64 Scope:Global
          inet6 addr: fe80::d267:e5ff:fef0:835e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18921 errors:0 dropped:0 overruns:0 frame:0
          TX packets:158 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1473313 (1.4 MiB)  TX bytes:18471 (18.0 KiB)

Comment 1 Martin Pavlik 2014-04-02 07:42:19 UTC
Created attachment 881657 [details]
TUI after choosing disable ipv6

Comment 2 wanghui 2014-04-03 10:10:59 UTC
hi Martin Pavlik,

I have tested this issue in RHEL6.5 GA build. And it the same issue as rhevh6.5.

Test steps:
1. Enable router advertisment to the network.
2. Install rhel6.5 GA.
3. Just enable eth1 with IPv4 dhcp mode.
#cat /etc/sysconfig/network-scripts/ifcfg-eth1
 DEVICE=eth1
 HWADDR=52:54:00:0A:A4:AD
 TYPE=Ethernet
 UUID=30f83d20-2f59-4ba9-962c-64476154c995
 ONBOOT=no
 NM_CONTROLLED=yes
 BOOTPROTO=dhcp

Test result:
1. After step3, it can also get the IPv6 autoconf address as follows.
eth1      Link encap:Ethernet  HWaddr 52:54:00:0A:A4:AD  
          inet addr:192.168.15.17  Bcast:192.168.15.255  Mask:255.255.255.0
          inet6 addr: 300::5054:ff:fe0a:a4ad/64 Scope:Global
          inet6 addr: fe80::5054:ff:fe0a:a4ad/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:182 errors:0 dropped:0 overruns:0 frame:0
          TX packets:90 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:20694 (20.2 KiB)  TX bytes:14320 (13.9 KiB)

So first thing is that we keep the same behaves as RHEL does.

The second thing is that I found maybe it is the advantage that IPv6 vs IPv4. For IPv6, if the host receive a router advertisement which is stateless, it can generate its own ipv6 autoconfigure address.[1]
And we also can check this by the follows.

#sysctl -a |grep net.ipv6.conf.default.autoconf
 net.ipv6.conf.default.autoconf = 1
From the output, we can see, the autoconfig is enabled as default when we load the ipv6 model.

So in my opinion, it's not a issue. Because that's designed to be like this and that is one of the ipv6 advantage. Once we load IPv6 model, we can get the ipv6 address if host received the router's advertisement.

And because it gives the ipv6 link address, it illustrates that ipv6 model is loaded. So the auto configure is enabled by default. 

Ref link:[1] http://en.wikipedia.org/wiki/IPv6#Stateless_address_autoconfiguration_.28SLAAC.29 of SLAAC part

Comment 3 Martin Pavlik 2014-04-03 11:04:19 UTC
(In reply to wanghui from comment #2)

hi, 

the point of this BZ is that if I specify to disable IPv6 it should get disabled (at least for particular interface), which does not happen, 

if RHEV-H was not supposed to allow this, then the option disable IPv6 should not be there at all

Comment 4 wanghui 2014-04-04 02:17:44 UTC
Hi Martin Pavlik,

If you think it should be better to disable IPv6 in RHEV-H when you selected disabled, then maybe you should also can't get the ipv6 link address. Because once you load the IPv6 model, it will enabled the IPv6 function.

Because the IPv6 model is loaded by default, the same as RHEL. So why you want to disable the ipv6?

Thanks
Hui Wang

(In reply to Martin Pavlik from comment #3)
> (In reply to wanghui from comment #2)
> 
> hi, 
> 
> the point of this BZ is that if I specify to disable IPv6 it should get
> disabled (at least for particular interface), which does not happen, 
> 
> if RHEV-H was not supposed to allow this, then the option disable IPv6
> should not be there at all

Comment 5 Martin Pavlik 2014-04-25 06:20:53 UTC
(In reply to wanghui from comment #4)
> Hi Martin Pavlik,
> 
> If you think it should be better to disable IPv6 in RHEV-H when you selected
> disabled, then maybe you should also can't get the ipv6 link address.
> Because once you load the IPv6 model, it will enabled the IPv6 function.
> 
> Because the IPv6 model is loaded by default, the same as RHEL. So why you
> want to disable the ipv6?
> 
> Thanks
> Hui Wang
> 
> (In reply to Martin Pavlik from comment #3)
> > (In reply to wanghui from comment #2)
> > 
> > hi, 
> > 
> > the point of this BZ is that if I specify to disable IPv6 it should get
> > disabled (at least for particular interface), which does not happen, 
> > 
> > if RHEV-H was not supposed to allow this, then the option disable IPv6
> > should not be there at all

Please read BZ description:

--------------------------------------------------------------------------------
Actual results:
If user picks to disable IPv6 in TUI NIC configuration dialog IPv6 does not get disabled (see screenshots)for the particular interface

Expected results:
If user picks to disable IPv6 in TUI NIC configuration dialog IPv6 is disabled for the particular interface

--------------------------------------------------------------------------------

All I am saying is that we have button which gives the user a choice to disable IPv6 for interface. If user for whatever reason decides to use it, it should work. 

So nottom line is, either we fix it or remove the option

Comment 6 Joey Boggs 2014-05-21 01:19:13 UTC
Disabled option was originally mean to mean "unconfigured" but indeed it should work.

Patch now disables ipv6 unless explicitly enabled

Comment 8 Yaning Wang 2014-12-18 06:14:15 UTC
Created attachment 970395 [details]
ifconfig_output

Tested on:

RHEV-H 6.6-20141212.0.el6ev
ovirt-node-3.1.0-0.34.el6


Test steps:

1. install RHEV-H
2. Network -> eth0 -> enter -> ok
3. IPv4 settings -> DHCP
4. IPv6 settings -> Disabled 

Actual results:

still can obtain ipv6 address via DHCP even though ipv6 is disabled in TUI

Comment 10 Fabian Deutsch 2015-02-11 13:49:20 UTC
Adjusting the priority. We basically can not disbale IPv6 completely, but we weren't able to do this in the past as well, thus I do not expect more problems.


Note You need to log in before you can comment on or make changes to this bug.