Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1083307 - OVIRT35 - [RFE] support migrating existing virtual machines on oVirt/RHEV storage between setups
Summary: OVIRT35 - [RFE] support migrating existing virtual machines on oVirt/RHEV sto...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Maor
QA Contact: Aharon Canan
URL: http://www.ovirt.org/Features/ImportS...
Whiteboard: storage
: 773318 983749 (view as bug list)
Depends On:
Blocks: 716511
TreeView+ depends on / blocked
 
Reported: 2014-04-01 22:09 UTC by Allon Mureinik
Modified: 2016-02-10 19:43 UTC (History)
25 users (show)

Fixed In Version: ovirt-engine-3.5.0_alpha2
Doc Type: Enhancement
Doc Text:
Clone Of: 716511
Environment:
Last Closed: 2014-10-17 12:21:56 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24286 None None None Never
oVirt gerrit 25947 master MERGED core: Add snapshot to the OVF generation Never
oVirt gerrit 26480 None None None Never
oVirt gerrit 26483 None None None Never
oVirt gerrit 26484 None None None Never
oVirt gerrit 27247 None None None Never
oVirt gerrit 27307 None None None Never
oVirt gerrit 27581 None None None Never

Description Allon Mureinik 2014-04-01 22:09:22 UTC
+++ This bug was initially created as a clone of Bug #716511 +++

Attach and detach an existing data domain form a data center, in order to move disks and VMs stored on it between DCs, or even set-ups.

Comment 1 Allon Mureinik 2014-05-17 08:10:48 UTC
Maor, should this be on POST?

Comment 2 Maor 2014-05-17 20:50:29 UTC
There are patches upstream waiting to be merged which will support
Detach/Attach of Storage Domains.
http://gerrit.ovirt.org/#/q/status:open+project:ovirt-engine+branch:master+topic:Detach_Attach_StorageDomain,n,z,

Currently it only supports moving Storage Domains (Containing
disks/VMs/Templates) from one DC to another.

The next phase of patches should be to support import of Storage
Domains, that can be implemented only after after
http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:retrieve-image,n,z
will be merged.
Once those patches will be upstream, I will change the bug to post.

Comment 3 Maor 2014-05-17 20:52:40 UTC
I now saw that this bug is only related to attach/detach.
Changing it to post

Comment 5 Maor 2014-05-18 19:16:09 UTC
(In reply to Pablo Iranzo Gómez from comment #4)
> (In reply to Maor from comment #3)
> > I now saw that this bug is only related to attach/detach.
> > Changing it to post
> 
> Maor, it says:
> 
> "Attach and detach an existing data domain form a data center, in order to
> move disks and VMs stored on it between DCs, or even set-ups."
> 
> Some of my customers are interested in the last part "or even set-ups".
> 
> Does this BZ will still cover that? the idea they have is to be able to
> detach a working SD from a DC, and on another rhev setup, be able to attach
> that SD to the DC, so they can effectively move a full SD without having to
> go via export/import on each vm.
> 
> Thanks
> Pablo

In that case, it should be supported only after for http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:retrieve-image,n,z will be merged, and wait for the next phase of patches to be submitted.

Comment 6 Itamar Heim 2014-08-04 09:14:02 UTC
*** Bug 773318 has been marked as a duplicate of this bug. ***

Comment 7 Itamar Heim 2014-08-04 12:02:08 UTC
*** Bug 983749 has been marked as a duplicate of this bug. ***

Comment 8 Sandro Bonazzola 2014-10-17 12:21:56 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.