Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1083203 - virt-viewer doesn't automatically adjust resolution when opened fullscreen via vv-file
Summary: virt-viewer doesn't automatically adjust resolution when opened fullscreen vi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer
Version: 6.6
Hardware: Unspecified
OS: Unspecified
urgent
low
Target Milestone: rc
: ---
Assignee: Jonathon Jongsma
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1076243 1092871
TreeView+ depends on / blocked
 
Reported: 2014-04-01 16:29 UTC by Jonathon Jongsma
Modified: 2018-12-03 21:06 UTC (History)
12 users (show)

Fixed In Version: virt-viewer-0.6.0-2.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, when a virt-viewer console was launched from the Red Hat Enterprise Virtualization user portal with the 'Native Client' invocation method and 'Open in Full Screen' was selected, the displays of the guest virtual machine were not always configured to match the client displays. After this update, virt-viewer will show a full-screen guest display for each client monitor.
Clone Of:
Environment:
Last Closed: 2014-10-14 06:30:43 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposed fix (deleted)
2014-04-01 17:11 UTC, Jonathon Jongsma
no flags Details | Diff
remote-viewer log with --spice-debug (deleted)
2014-06-11 01:58 UTC, CongDong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 776553 None None None Never
Red Hat Product Errata RHBA-2014:1379 normal SHIPPED_LIVE virt-viewer bug fix update 2014-10-14 01:05:43 UTC

Description Jonathon Jongsma 2014-04-01 16:29:04 UTC
When remove-viewer is launched via 'native client' method (i.e. vv-file) from the RHEV user portal, it is supposed to auto-configure the resolution to match the client monitor configuration. However, the vv-file format does not have any key to indicate that the client should do auto-conf, it only has a single 'fullscreen' key.  

In upstream virt-viewer, the 'basic' fullscreen mode has been removed and we will always do auto-conf whenever we start in fullscreen.  So it doesn't make sense to change both RHEV and virt-viewer to include an additional auto-conf key in the vv file, since it will just have to be reverted soon.  But we could simply change virt-viewer to enable auto-conf whenever 'fullscreen' is set in the vv file.

Comment 1 Jonathon Jongsma 2014-04-01 17:11:44 UTC
Created attachment 881459 [details]
proposed fix

This patch enables auto-conf when fullscreen is specified in vv-file

Comment 2 Marc-Andre Lureau 2014-04-01 17:24:36 UTC
(In reply to Jonathon Jongsma from comment #1)
> Created attachment 881459 [details]
> proposed fix
> 
> This patch enables auto-conf when fullscreen is specified in vv-file

Personally, I am fine with this. however it is a change of behaviour. I think we should get ack on 1027381 first. Or we can opening another bug for the non-autoconf case after this...

Comment 3 David Blechter 2014-04-02 22:43:17 UTC
(In reply to Marc-Andre Lureau from comment #2)
> (In reply to Jonathon Jongsma from comment #1)
> > Created attachment 881459 [details]
> > proposed fix
> > 
> > This patch enables auto-conf when fullscreen is specified in vv-file
> 
> Personally, I am fine with this. however it is a change of behaviour. 

Can you clarify?
The purpose of this bug is to change the behaviour, and make it identical to the plugin one.

> think we should get ack on 1027381 first. Or we can opening another bug for
> the non-autoconf case after this...

1027381 is rfe, and it does not apply to the z-stream. The proposed patch is the temporary solution for customers using rhel and windows spice client in rhevm 3.3 and 3.4 environments.

Comment 4 Marc-Andre Lureau 2014-04-02 22:52:44 UTC
(In reply to David Blechter from comment #3)
> (In reply to Marc-Andre Lureau from comment #2)
> > (In reply to Jonathon Jongsma from comment #1)
> > > Created attachment 881459 [details]
> > > proposed fix
> > > 
> > > This patch enables auto-conf when fullscreen is specified in vv-file
> > 
> > Personally, I am fine with this. however it is a change of behaviour. 
> 
> Can you clarify?
> The purpose of this bug is to change the behaviour, and make it identical to
> the plugin one.

This patch makes it do auto-conf, always when fullscreen.

Is it what the plugin is doing? Afaik, with the plugin/controller, you can have either auto-conf or non-auto-conf.

I am just saying that doing always auto-conf is equally wrong as doing always non-auto-conf (as currently)

Comment 5 David Blechter 2014-04-29 17:19:18 UTC
It was agreed with Andy Cathrow to implement the temp solution as was proposed in description: "...change virt-viewer to enable auto-conf whenever 'fullscreen' is set in the vv file"

Comment 10 CongDong 2014-05-05 06:59:43 UTC
I test with virt-viewer-0.5.6-10.el6.x86_64
Steps:
1. Prepare a spice guest on rhevm and a client with more than one onitors
2. Configure the guest with "native client" and "Open in Full Screen"
3. Download "console.vv" file
4. #remote-viewer console.vv --debug

Result:
I got 2 problems:
1. When use a windows guest, if I configure the guest with only one display first, it cannot open 4 displays to match the client. But after I try 2 or 3 times, it works fine with 4 displays

2. If use rhel guest, and configure the guest with only one display first, it just open one display.

As the result, ASSIGNED.

Comment 11 CongDong 2014-06-06 10:33:34 UTC
I test with virt-viewer-0.6.0-5.el6.x86_64

Steps:
1. Prepare a spice guest on rhevm and a client with 4 onitors
2. Configure the guest with "native client" and "Open in Full Screen"
3. Download "console.vv" file
4. #remote-viewer console.vv --debug

Result:
If use windows guest, still got the problem, If I configure the windows guest with only one display, then I connect the guest with vv file.

first time:
# remote-viewer consolve.vv 
two displays show with fullscreen

second time:
# remote-viewer consolve.vv 
three displays show with fullscreen

third time:
# remote-viewer consolve.vv 
four displays show with fullscreen

windows 7 and windows xp get the same result
As the result, I think the problem is not fixed.

Comment 12 Marc-Andre Lureau 2014-06-06 17:18:44 UTC
hmm, works for me..

Please provide SPICE_DEBUG=1

In particular, look for first lines like:

(remote-viewer:32093): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #0 1600x817+0+0 @ 32 bpp
(remote-viewer:32093): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #1 400x377+0+0 @ 32 bpp
(remote-viewer:32093): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #2 400x377+0+0 @ 32 bpp


This should match your client config.

Jonathon, is it expected that there is no +x offset here? shouldn't it match the client xrandr config?

Comment 13 Jonathon Jongsma 2014-06-06 17:59:04 UTC
hmm.  a x offset of 0 looks a bit suspicious. I would expect it to match the client xrander config, yes.

Comment 14 Marc-Andre Lureau 2014-06-10 12:21:12 UTC
Hi CongDong, please reply to comment #12, thanks

Comment 15 CongDong 2014-06-11 01:58:27 UTC
Created attachment 907460 [details]
remote-viewer log with --spice-debug

Log for remote-viewer
I tested with win7 guest, configure it with only 1 display first, I use remote-viewer to connect it, only two displays come out, but there are 4 monitors.

Comment 16 Marc-Andre Lureau 2014-06-11 13:32:33 UTC
(In reply to CongDong from comment #15)
> Created attachment 907460 [details]
> remote-viewer log with --spice-debug
> 
> Log for remote-viewer
> I tested with win7 guest, configure it with only 1 display first, I use
> remote-viewer to connect it, only two displays come out, but there are 4
> monitors.

I can't reproduce.

it's not clear what's going on from the log, it seems initial setup sent to guest is fine:

(remote-viewer:3437): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #0 1280x1024+0+0 @ 32 bpp
(remote-viewer:3437): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #1 1280x1024+1280+0 @ 32 bpp
(remote-viewer:3437): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #2 1680x1050+2560+0 @ 32 bpp
(remote-viewer:3437): GSpice-DEBUG: channel-main.c:1176 main-1:0: monitor config: #3 1280x1024+4240+0 @ 32 bpp

But then we get display 0 ok, and display 3 setup n times!, this happens 3 times:

(remote-viewer:3437): GSpice-DEBUG: spice-widget.c:2121 update area, primary: 1280x1024, area: +0+0 1280x1024
(remote-viewer:3437): GSpice-DEBUG: spice-widget.c:1055 recalc geom monitor: 3:0, guest +0+0:1280x1024, window 1280x1024, zoom 1
(remote-viewer:3437): GSpice-DEBUG: channel-display.c:904 display-2:3: display_handle_mark
(remote-viewer:3437): GSpice-DEBUG: spice-widget.c:2215 widget mark: 1, 3:0 0xb211f0

I think this is a bug in the guest, perhaps a memory configuration issue? (I have ram/vram of 64m)

Could you provide windows vdagent.log? thanks

Comment 17 Jonathon Jongsma 2014-06-11 13:39:59 UTC
Didn't we just cover the exact same situation in bug 1092871? Please verify that starting virt-viewer with vv-file works exactly the same as it does when starting it via the browser plugin.  If both fail for 4 displays, it's a different bug.

Comment 18 CongDong 2014-06-16 06:47:11 UTC
(In reply to Jonathon Jongsma from comment #17)
> Didn't we just cover the exact same situation in bug 1092871? Please verify
> that starting virt-viewer with vv-file works exactly the same as it does
> when starting it via the browser plugin.  If both fail for 4 displays, it's
> a different bug.

I retest with broswer plugin, the result is same with native client mode.
Like I said in comment 11

Comment 19 Jonathon Jongsma 2014-06-16 15:10:11 UTC
If it works the same with browser plugin and native client, then I consider this bug fixed.

Comment 20 Marc-Andre Lureau 2014-06-18 14:34:36 UTC
moving back to onqa

Comment 21 CongDong 2014-06-19 08:35:45 UTC
Test with virt-viewer-0.6.0-7.el6.x86_64

Update qxl driver fo the guest to latest, don't get the problem of rhel guest in comment 10.
4 displays will comes out in each monitor with fullscreen mode, the resolution is right.

Problem of windows guest is still there, as comment 17, it's a different one.

So verify this.

Comment 22 CongDong 2014-06-19 08:44:21 UTC
Steps for comment 21
1. install rhel guest on rhevm
2. configure the guest with only one display
3. make sure option "open in fullscreen " is checked, download the vv file in "native mode"
4. # remote-vieewr console.vv

Result:
4 displays will comes out in each monitor with fullscreen mode, the resolution is right.

Also test with "broswer plugin" mode, it works well with 2 and 4 monitors.

I'll file a new one to track problem of windows guest

Comment 23 errata-xmlrpc 2014-10-14 06:30:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1379.html


Note You need to log in before you can comment on or make changes to this bug.