Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1083106 - Provide a bit more space and/or limit length of bond names to fit in the availabel space
Summary: Provide a bit more space and/or limit length of bond names to fit in the avai...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.4.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On:
Blocks: 1118297 1120063 1123329 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-04-01 13:38 UTC by Martin Pavlik
Modified: 2016-02-10 20:09 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-3.0.1-18.el6_5.13
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1120063 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:54:53 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 26372 None None None Never

Description Martin Pavlik 2014-04-01 13:38:02 UTC
Created attachment 881353 [details]
screenshot 1

Description of problem:
RHEV-H TUI -> Network -> Available System NICs , allow more space for bond names

Since we allow for bond names in following shape

bond+number(max 11 digits) 

TUI should be able to display them.

At the moment TUI can display only bond+3 digits see screenshot 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140320.0.el6ev)

How reproducible:
100% 

Steps to Reproduce:
1. add RHEV-H to RHEV-M
2. create bond named "bond01234567890" on the RHEV-H host

Actual results:
At the moment TUI can display only bond+3 digits see screenshot 

Expected results:
Full bond name visible

Additional info:

Comment 1 Fabian Deutsch 2014-04-01 14:05:40 UTC
To let all the data fit in our 80x24 minimal setup we should do it the other way round and limit the maximum length of bond names, or do a mix of both (limit the length, and provide more space).

In general we should not break the 80x24 limits.

Comment 2 Ryan Barry 2014-04-01 14:40:26 UTC
Is this bond created from the RHEV-M interface? You should not have the option to create bonds from RHEV-H when managed by RHEV-M, and the attachment reflects this (disabled button).

Comment 5 Yaning Wang 2014-12-18 02:42:46 UTC
Tested on:

RHEV-H 6.6-20141212.0.el6ev
ovirt-node-3.1.0-0.34.el6



Steps to Reproduce:
1. clean install rhevh
2. add RHEV-H to RHEV-M
3. create bond named "bond01234567890" on the RHEV-H host

Actual results:
bond create successful 
Full bond name visible

Comment 7 errata-xmlrpc 2015-02-11 20:54:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.