Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1082959 - [Selector] durable field cannot be used
Summary: [Selector] durable field cannot be used
Keywords:
Status: CLOSED DUPLICATE of bug 1083015
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: messaging-bugs
QA Contact: MRG Quality Engineering
URL:
Whiteboard:
Depends On:
Blocks: 453539
TreeView+ depends on / blocked
 
Reported: 2014-04-01 07:55 UTC by Zdenek Kraus
Modified: 2014-04-01 13:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-01 13:16:53 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Zdenek Kraus 2014-04-01 07:55:50 UTC
Description of problem:
filter addressing the durable filed is not working

Version-Release number of selected component (if applicable):
qpid-cpp-server-0.22-36

How reproducible:
100%

Steps to Reproduce:
1. ./qc2_spout --log-msgs dict -c 2 "q;{create:always}"
2. ./qc2_drain --log-msgs dict -c 1 "q;{link:{selector:\"amqp.durable = false\"}}"
2. ./qc2_drain --log-msgs dict -c 1 "q;{link:{selector:\"durable = False\"}}"
4. ./qc2_drain --connection-options "{protocol:amqp1.0}" --log-msgs dict -c 1 "q;{link:{selector:\"amqp.durable = False\"}}"
5. ./qc2_drain --connection-options "{protocol:amqp1.0}" --log-msgs dict -c 1 "q;{link:{selector:\"durable = False\"}}"
6. ./qc2_drain --log-msgs dict -c 1 "q;{link:{selector:\"amqp.redelivered = False\"}}"
7. ./qc2_drain --connection-options "{protocol:amqp1.0}" --log-msgs dict -c 1 "q;{link:{selector:\"amqp.redelivered = False\"}}"



Actual results:
[1]
{'redelivered': False, 'reply_to': None, 'subject': None, 'content_type': None, 'id': None, 'user_id': None, 'correlation_id': None, 'priority': 0, 'durable': False, 'ttl': 0, 'properties': {'spout-id': '9acc400e-3740-48bb-8604-90bc8e8e459e:0'}, 'content': None}
{'redelivered': False, 'reply_to': None, 'subject': None, 'content_type': None, 'id': None, 'user_id': None, 'correlation_id': None, 'priority': 0, 'durable': False, 'ttl': 0, 'properties': {'spout-id': 'b4033095-7b5d-41f0-a994-1d9d48a243ac:1'}, 'content': None}

[2] nothing
[3] nothing
[4] nothing
[5] nothing
[6]
{'redelivered': False, 'reply_to': None, 'subject': None, 'content_type': None, 'id': None, 'user_id': None, 'correlation_id': None, 'priority': 0, 'durable': False, 'ttl': 0, 'properties': {'spout-id': '9acc400e-3740-48bb-8604-90bc8e8e459e:0', 'x-amqp-0-10.routing-key': 'q'}, 'content': None}

[7]
{'redelivered': False, 'reply_to': None, 'subject': None, 'content_type': None, 'id': None, 'user_id': None, 'correlation_id': None, 'priority': 0, 'durable': False, 'ttl': 0, 'properties': {'spout-id': 'b4033095-7b5d-41f0-a994-1d9d48a243ac:1'}, 'content': None}

Expected results:
[2] and [4] should receive the messages by amqp.durable = False is definitely true selector

Additional info:

Comment 3 Zdenek Kraus 2014-04-01 11:25:58 UTC
this could be tracked by another selector header field bugzilla Bug 1083015, where I mentioned other header fields.

Requesting CLOSE DUPLICATE.

Comment 4 Justin Ross 2014-04-01 13:16:53 UTC
Okay, agreed.  Thanks!

(In reply to Zdenek Kraus from comment #3)
> this could be tracked by another selector header field bugzilla Bug 1083015,
> where I mentioned other header fields.
> 
> Requesting CLOSE DUPLICATE.

*** This bug has been marked as a duplicate of bug 1083015 ***


Note You need to log in before you can comment on or make changes to this bug.