Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1082694 - ISE when deleting value from custom system info key edit page
Summary: ISE when deleting value from custom system info key edit page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI
Version: 560
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On:
Blocks: 465198 sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-03-31 16:09 UTC by Shannon Hughes
Modified: 2018-12-05 17:56 UTC (History)
3 users (show)

Fixed In Version: spacewalk-java-2.0.2-71-sat
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-30 14:11:20 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0807 normal SHIPPED_LIVE cobbler and spacewalk bug fix update 2014-06-30 18:09:37 UTC

Description Shannon Hughes 2014-03-31 16:09:33 UTC
Description of problem:

ISE on UpdateCustomData.do when clicking "delete value" link. 

delete value should not be shown when editing/adding a new custom info key/value pair for a system. 


How reproducible: always


Steps to Reproduce:
1. systems->details-custom info
2. create a key/description
3. go to system and click on custom info tab
4. click on create new value
5. select the key that was created in #2
6. note that while in edit mode there is a delete value link which should not be displayed since the record has not yet been created
7. clicking on delete value link causes ISE

will work on patch for github pull request

Comment 8 Stephen Herr 2014-05-06 15:37:33 UTC
Patch accepted, thanks Shannon.

Committing to Spacewalk master as:
b32911d260b01b28a26d855df5cd69c8e44f90fa

Comment 13 errata-xmlrpc 2014-06-30 14:11:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0807.html


Note You need to log in before you can comment on or make changes to this bug.