Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1082594 - [rhevm-cli]: update vm has no --memory_policy-guaranteed option
Summary: [rhevm-cli]: update vm has no --memory_policy-guaranteed option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-sdk
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Ilanit Stein
URL:
Whiteboard: sla
: 1125331 (view as bug list)
Depends On:
Blocks: 1122945 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-31 12:27 UTC by Ilanit Stein
Modified: 2016-02-10 20:14 UTC (History)
14 users (show)

Fixed In Version: rhevm-sdk-python-3.5.0.3-1.el6_5
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Clone Of:
: 1122945 (view as bug list)
Environment:
Last Closed: 2015-02-11 21:13:26 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0183 normal SHIPPED_LIVE rhevm-sdk-python bug fix and enhancement update 2015-02-12 01:36:21 UTC
oVirt gerrit 29936 master MERGED restapi: Fix update VM optional parameters Never
oVirt gerrit 30007 ovirt-engine-3.5 MERGED restapi: Fix update VM optional parameters Never
oVirt gerrit 30683 ovirt-engine-3.4 MERGED restapi: Fix update VM optional parameters Never

Description Ilanit Stein 2014-03-31 12:27:18 UTC
Description of problem:
On cli, unlike in rest, update vm  --memory_policy-guaranteed option do not exist.

Version-Release number of selected component (if applicable):
av5


Actual results:
2014-03-31 07:55:34,396 - MainThread - vms - WARNING - Generated command:
update vm restvm_update  --memory_policy-guaranteed 536870912 --correlation_id 431
2014-03-31 07:55:34,765 - MainThread - events - DEBUG - Autocompletion options:
set(['comment', 'origin', 'custom_properties-custom_property', 'placement_policy-affinity', 'cpu-mode', 'os-boot', 'correlation_id', 'domain-name', 'virtio_scsi-enabled', 'timezone', 'migration_downtime', 'description', 'os-cmdline', 'sso-methods-method', 'display-type', 'os-initRd', 'content', 'cpu-topology-cores', 'delete_protected', 'memory', 'high_availability-priority', 'tunnel_migration', 'payloads-payload', 'cluster-id', 'cluster-name', 'os-type', 'cpu-cpu_tune-vcpu_pin', 'display-allow_override', 'console-enabled', 'usb-enabled', 'usb-type', 'placement_policy-host-name', 'use_latest_template_version', 'stateless', 'name', 'display-single_qxl_pci', 'type', 'display-smartcard_enabled', 'os-kernel', 'high_availability-enabled', 'cpu-architecture', 'placement_policy-host-id', 'display-keyboard_layout', 'cpu-topology-sockets', 'display-monitors', 'cpu_shares'])

Expected results:
To have --memory_policy-guaranteed option for update vm

Blocking test:
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Compute/view/3.4-git/view/Virt/job/3.4-git-compute-virt-reg_vms-cli-nfs/48/

Comment 1 Juan Hernández 2014-03-31 13:09:11 UTC
This happens because the memory policy isn't correctly documented in the RESTAPI metadata .yaml file. Once this is fixed in the engine the Python SDK will need to be regenerated.

Comment 3 Juan Hernández 2014-07-11 10:55:34 UTC
This is a very simple modification of the metadata, so I'm taking it. Once the fix is merged the SDKs will need to be regenerated.

Comment 4 Juan Hernández 2014-07-14 09:27:56 UTC
The fix for this issue has been merged into the upstream 3.5 branch, it will be available downstream with the next rebase.

Comment 5 Juan Hernández 2014-07-14 14:19:35 UTC
In order to fix this completely the Python SDK needs to be regenerated.

Comment 7 Juan Hernández 2014-07-18 10:45:58 UTC
This will be fixed rebasing from upstrem 3.5.0.3.

Comment 10 Ilanit Stein 2014-08-07 12:05:27 UTC
with these version ovirt-shell update vm -- auto completion still has no option named --memory_policy-guaranteed

ovirt-engine-sdk-python-3.5.0.4-1.20140728.gitec31051.el6.noarch
oVirt Engine Version: 3.5.0-0.0.master.20140804172041.git23b558e.el6

Comment 11 Juan Hernández 2014-08-21 10:35:38 UTC
This issue was fixed in rhevm-sdk-python-3.5.0.3-1.el6_5. Make sure that you use that package for your tests, otherwise the results aren't valid.

Comment 12 Juan Hernández 2014-08-25 09:46:52 UTC
*** Bug 1125331 has been marked as a duplicate of this bug. ***

Comment 13 Artyom 2014-09-02 07:03:14 UTC
Verified on ovirt-engine-sdk-python-3.5.0.5-1.20140820.gitc47c189.el6.noarch

Comment 15 errata-xmlrpc 2015-02-11 21:13:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0183.html


Note You need to log in before you can comment on or make changes to this bug.