Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1082479 - OVIRT35 - [RFE] add support for disabling spice agent based file transfer and copy&paste
Summary: OVIRT35 - [RFE] add support for disabling spice agent based file transfer and...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Francesco Romani
QA Contact: Artyom
URL:
Whiteboard: virt
: 1052959 (view as bug list)
Depends On:
Blocks: 800155 983019
TreeView+ depends on / blocked
 
Reported: 2014-03-31 07:25 UTC by Francesco Romani
Modified: 2016-02-10 19:49 UTC (History)
9 users (show)

Fixed In Version: ovirt-engine-3.5.0_beta
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:23:52 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23270 master ABANDONED vm: spice support to agent file transfer disable Never
oVirt gerrit 26241 master MERGED backend: spice: add support to control the user data transfer Never
oVirt gerrit 26244 master MERGED frontend: spice: expose support to control the user data transfer Never
oVirt gerrit 26365 master MERGED restapi: spice: expose support to control the user data transfer Never
oVirt gerrit 28149 master ABANDONED backend: spice: allow to disable the clipboard Never
oVirt gerrit 28150 master ABANDONED frontend: spice: allow to disable the clipboard Never
oVirt gerrit 28151 master ABANDONED restapi: spice: allow to disable the clipboard Never

Description Francesco Romani 2014-03-31 07:25:36 UTC
Description of problem:
spice has agent based file transfer support. In some environments there might be a desire to turn this off. Libvirt support this option since version 1.2.2

This bug is for tracking exposing support for this to oVirt.

Comment 1 Michal Skrivanek 2014-03-31 07:34:11 UTC
additionally we want to expose "disable copy & paste" option as well

Comment 2 Itamar Heim 2014-04-24 19:52:07 UTC
duplicate of bug 1052959?

Comment 3 Michal Skrivanek 2014-04-28 09:42:12 UTC
*** Bug 1052959 has been marked as a duplicate of this bug. ***

Comment 4 Francesco Romani 2014-06-13 15:30:21 UTC
fully merged.
filetransfer support is present but disabled for 3.5 due to packaging troubles which lead to patch not merged in VDSM.

Comment 5 Jiri Belka 2014-08-01 09:43:29 UTC
u/s for BZ800155.

Comment 6 Artyom 2014-08-07 14:53:19 UTC
Verified on ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

Comment 7 Sandro Bonazzola 2014-10-17 12:23:52 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.