Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1081216 - Enable ppc64le in qt
Summary: Enable ppc64le in qt
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-26 19:01 UTC by Brent Baude
Modified: 2014-03-26 20:35 UTC (History)
9 users (show)

Fixed In Version: qt-4.8.5-24.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-26 20:35:49 UTC


Attachments (Terms of Use)
qt arch define for ppc64le (deleted)
2014-03-26 19:01 UTC, Brent Baude
no flags Details | Diff

Description Brent Baude 2014-03-26 19:01:50 UTC
Created attachment 879173 [details]
qt arch define for ppc64le

For the latest rawhide qt to build for ppc64le, we need a trivial patch and trivial spec changes implemented.  The spec changes are as follows:

[baude@ppc64le qt]$ git diff
diff --git a/qt.spec b/qt.spec
index 3041aad..1cdc439 100644
--- a/qt.spec
+++ b/qt.spec
@@ -5,8 +5,8 @@
 %define no_pch -no-pch
 
 # See http://bugzilla.redhat.com/223663
-%define multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9
-%define multilib_basearchs x86_64 ppc64 s390x sparc64
+%define multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9 ppc64le
+%define multilib_basearchs x86_64 ppc64 s390x sparc64 ppc64le
 
 %if 0%{?fedora} > 16 || 0%{?rhel} > 6
 # use external qt_settings pkg
@@ -174,6 +174,9 @@ Patch1147: 0147-Disallow-deep-or-widely-nested-entity-references.patch
 # https://codereview.qt-project.org/#change,71010
 Patch1162: 0162-Fully-expand-entities-to-ensure-deep-or-widely-neste.patch
 
+# ppc64le support
+Patch999: qt-everywhere-opensource-src-4.8-ppc64le_support.patch
+
 ## security patches
 
 # desktop files
@@ -550,6 +553,8 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
 %patch85 -p1 -b .QTBUG-35460
 %patch86 -p1 -b .systemtrayicon
 
+%patch999 -p1
+
 # drop -fexceptions from $RPM_OPT_FLAGS
 RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`

Comment 1 Rex Dieter 2014-03-26 20:35:49 UTC
Thanks.

%changelog
* Wed Mar 26 2014 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-24
- support ppc64le arch (#1081216)


Note You need to log in before you can comment on or make changes to this bug.