Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1081142 - FTBFS against libmikmod-3.3.6 (works with libmikmod-3.3.5)
Summary: FTBFS against libmikmod-3.3.6 (works with libmikmod-3.3.5)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mikmod
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-26 16:10 UTC by Jaromír Cápík
Modified: 2016-02-01 02:00 UTC (History)
5 users (show)

Fixed In Version: libmikmod-3.3.6-2.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-05 04:53:16 UTC


Attachments (Terms of Use)

Description Jaromír Cápík 2014-03-26 16:10:26 UTC
Description of problem:
mikmod-3.2.5-1 fails to build with libmikmod-3.3.6-1, but doesn't fail with libmikmod-3.3.5-1 ...

--------------
checking for libmikmod-config... /usr/bin/libmikmod-config
checking for libmikmod - version >= 3.1.5... no
*** Could not run libmikmod test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means libmikmod was incorrectly installed
*** or that you have moved libmikmod since it was installed. In the latter case, you
*** may want to edit the libmikmod-config script: /usr/bin/libmikmod-config
configure: error: 
--- ERROR: No suitable libmikmod library found.
           You need at least libmikmod 3.1.5 for this program to work.
--------------

Comment 1 Hans de Goede 2014-03-27 10:36:12 UTC
Actually this is caused by libmikmod 3.3.6 having pulse in its libmikmod-config --libs output. I'm preparing an updated libmikmod package which adds the necessary requires to libmikmod-devel.

Comment 2 Dan Horák 2014-03-27 10:46:53 UTC
(In reply to Hans de Goede from comment #1)
> Actually this is caused by libmikmod 3.3.6 having pulse in its
> libmikmod-config --libs output. I'm preparing an updated libmikmod package
> which adds the necessary requires to libmikmod-devel.

Seeing something similar in freetype recently - isn't the correct solution to drop pulse from libmikmod-config --libs instead of adding the requires?

Comment 3 Hans de Goede 2014-03-27 11:12:21 UTC
(In reply to Dan Horák from comment #2)
> (In reply to Hans de Goede from comment #1)
> > Actually this is caused by libmikmod 3.3.6 having pulse in its
> > libmikmod-config --libs output. I'm preparing an updated libmikmod package
> > which adds the necessary requires to libmikmod-devel.
> 
> Seeing something similar in freetype recently - isn't the correct solution
> to drop pulse from libmikmod-config --libs instead of adding the requires?

That is technically the better solution, but it requires deviation from upstream / a patch which makes rebasing harder. So I prefer this solution, note that libmikmod does actually use symbols from libpulse, so the end result is the same, this won't cause unnecessary .so loading as having too much libs on the cmdline sometimes does.

Comment 4 Jaromír Cápík 2014-03-27 11:19:54 UTC
(In reply to Dan Horák from comment #2)
> (In reply to Hans de Goede from comment #1)
> > Actually this is caused by libmikmod 3.3.6 having pulse in its
> > libmikmod-config --libs output. I'm preparing an updated libmikmod package
> > which adds the necessary requires to libmikmod-devel.
> 
> Seeing something similar in freetype recently - isn't the correct solution
> to drop pulse from libmikmod-config --libs instead of adding the requires?

That cannot be said for sure. The dependencies are sometimes transitive and mikmod might want to access some pulseaudio stuff directly. Someone has to dig in the code to confirm that.

Comment 5 Jaromír Cápík 2014-03-27 11:24:00 UTC
> note that libmikmod does actually use symbols from libpulse

Seem Hans has already checked that. In that case adding BR to libmikmod-devel is wiser.

Comment 6 Fedora Update System 2014-03-27 11:26:31 UTC
libmikmod-3.3.6-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libmikmod-3.3.6-2.fc20

Comment 7 Jaromír Cápík 2014-03-27 11:28:29 UTC
... I meant Requires, not BuildRequires.

Comment 8 Fedora Update System 2014-03-28 03:18:42 UTC
Package libmikmod-3.3.6-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libmikmod-3.3.6-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4447/libmikmod-3.3.6-2.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-04-05 04:53:16 UTC
libmikmod-3.3.6-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.