Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1080122 - hdf5 make check failed in ppc64le
Summary: hdf5 make check failed in ppc64le
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hdf5
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-24 17:42 UTC by Menanteau Guy
Modified: 2014-03-24 19:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-24 19:47:16 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2014-03-24 17:42:56 UTC
Description of problem:
Some tests failed in ppc64le because ppc64le arch is not guessed

Version-Release number of selected component (if applicable):
hdf5-1.8.12-5

How reproducible:
run rpmbuild with check enabled on ppc64le

Additional info:
need to patch bin/config.gues
--- hdf5-1.8.12/bin/config.guess.ori    
+++ hdf5-1.8.12/bin/config.guess        
@@ -921,6 +921,9 @@ EOF
     ppc64:Linux:*:*)
        echo powerpc64-unknown-linux-gnu
        exit ;;
+    ppc64le:Linux:*:*)
+       echo powerpc64le-unknown-linux-gnu
+       exit ;;
     alpha:Linux:*:*)
        case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
          EV5)   UNAME_MACHINE=alphaev5 ;;

Be carreful, this patch cannot be applied as is. bin/config.guess is prviously patched in the spec file by hdf5-aarch64.patch.

Comment 1 Orion Poplawski 2014-03-24 19:47:16 UTC
Thanks, applied.


Note You need to log in before you can comment on or make changes to this bug.