Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1079355 - [rhevm-reports-setup] Enable specifying a different DB server than the engine DB server
Summary: [rhevm-reports-setup] Enable specifying a different DB server than the engine...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: Pavel Novotny
URL:
Whiteboard: integration
Depends On:
Blocks: rhev3.5beta 1156165 1167313
TreeView+ depends on / blocked
 
Reported: 2014-03-21 13:05 UTC by Jiri Belka
Modified: 2015-02-11 18:17 UTC (History)
10 users (show)

Fixed In Version: oVirt Beta2
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1167313 (view as bug list)
Environment:
Last Closed: 2015-02-11 18:17:03 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC

Description Jiri Belka 2014-03-21 13:05:13 UTC
Description of problem:
remote DB server cannot be define, it is inherited from remote engine DB server. I want to define different DB server :)

# rhevm-reports-setup 
Welcome to rhevm-reports setup utility
In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote database not found.
Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:


                    ^^^^^ - no freedom to define remote DB server!
  
        create role <role> with login encrypted password '<password>';
        create database rhevmreports template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;

Database user: remote_reports
Database password: 
Editing XML files...                                  [ DONE ]
Setting DB connectivity...                            [ DONE ]
Please choose a password for the reports admin user(s) (rhevm-admin and superuser): 
Warning: Weak Password.
Re-type password:
...

Version-Release number of selected component (if applicable):
rhevm-reports-3.3.2-3.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. install engine with remote DB and dwh
2. rhevm-reports-setup
3.

Actual results:
no question about setting remote DB server

Expected results:
give me back the freedom to define remote DB server

Additional info:

Comment 1 Yaniv Lavi 2014-03-23 06:20:46 UTC
Will be considered for 3.5.0.



Yaniv

Comment 2 Yaniv Lavi 2014-05-08 10:21:09 UTC
should be in the code of first release. Please test once it's out.



Yaniv

Comment 5 Pavel Novotny 2014-11-07 15:58:23 UTC
Verified in rhevm-3.5.0-0.19.beta.el6ev.noarch (vt9).

Verification steps:
1. Do a clean install of RHEVM (no DWH or Reports), use remote engine DB during installation.
2. Install rhevm-dwh, run rhevm-setup and use the same remote DB host for DWH as was used in step 1.
3. Install rhevm-reports, run rhevm-setup and also specify remote DB for Reports.

Result:
Install script asks for remote DB host for Reports, snippet from installation process:
-~-
          --== DATABASE CONFIGURATION ==--
         
          Where is the Reports database located? (Local, Remote) [Local]: remote
         
          ATTENTION
         
          Manual action required.
          Please create database for ovirt-engine use. Use the following commands as an example:
         
          create role ovirt_engine_reports with login encrypted password 'ovirt_engine_reports';
          create database ovirt_engine_reports owner ovirt_engine_reports
           template template0
           encoding 'UTF8' lc_collate 'en_US.UTF-8'
           lc_ctype 'en_US.UTF-8';
         
          Make sure that database can be accessed remotely.
         
          Reports database host [localhost]: remotedb.example.com
          Reports database port [5432]: 
          Reports database secured connection (Yes, No) [No]: 
          Reports database name [ovirt_engine_reports]: reportsdb
          Reports database user [ovirt_engine_reports]: reports
          Reports database password: *****
          The detected DWH database size is 21 MB.
          Setup can backup the existing database.
          ... 
          Would you like to backup the existing database before upgrading it? (Yes, No) [Yes]: 
          ...
          ...
-~-

Comment 6 Yedidyah Bar David 2014-11-20 12:56:38 UTC
Yaniv - do we needs docs for this (in the bug or in docs)?

This already worked in 3.4, not sure about the status of official support etc.

Comment 7 Yaniv Lavi 2014-11-24 12:53:42 UTC
(In reply to Yedidyah Bar David from comment #6)
> Yaniv - do we needs docs for this (in the bug or in docs)?
> 
> This already worked in 3.4, not sure about the status of official support
> etc.

If it's not already included, then it need to be added to docs.

Comment 9 errata-xmlrpc 2015-02-11 18:17:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.