Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1079351 - [rhevm-dwh-setup] Enable specifying a different DB server than the engine DB server
Summary: [rhevm-dwh-setup] Enable specifying a different DB server than the engine DB ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Yedidyah Bar David
QA Contact: Pavel Novotny
URL:
Whiteboard: integration
Depends On:
Blocks: 1080997 1100200 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-21 13:00 UTC by Jiri Belka
Modified: 2015-02-11 18:14 UTC (History)
12 users (show)

Fixed In Version: oVirt Beta2
Doc Type: Bug Fix
Doc Text:
Previously, when using a remote database, the ovirt-engine-dwh-setup configured the host and engine databases on the same machine, and it was not possible to specify a different database host. In Red Hat Enterprise Virtualization 3.4, the DWH setup utility was replaced with a plug-in to use the common engine-setup utility and made it possible to input a database host as needed when setting up DWH with a remote database. This feature was a Tech Preview feature in Red Hat Enterprise Virtualization 3.4, and now a supported feature in 3.5.
Clone Of:
Environment:
Last Closed: 2015-02-11 18:14:45 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0177 normal SHIPPED_LIVE rhevm-dwh 3.5 bug fix and enhancement update 2015-02-11 23:11:50 UTC

Description Jiri Belka 2014-03-21 13:00:29 UTC
Description of problem:
remote DB server cannot be define, it is inherited from remote engine DB server. I want to define different DB server :)

# rhevm-dwh-setup 
Welcome to ovirt-engine-dwh setup utility

In order to proceed the installer must stop the ovirt-engine service
Would you like to stop the ovirt-engine service (yes|no): 
Would you like to stop the ovirt-engine service (yes|no): yes
Stopping ovirt-engine...                              [ DONE ]
Remote installation is selected.

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ - no freedom to let me chose DB server! :)

Remote installation selected. Make sure that DBA creates a user and the database in the following fashion:
        create role <role> with login encrypted password <password>;
        create database ovirt_engine_history template template0 encoding 'UTF8' lc_collate 'en_US.UTF-8' lc_ctype 'en_US.UTF-8' owner <role>;

Database user [engine_history]: remote_history
Database password: 
Creating DB Schema...                                 [ DONE ]
Setting DB connectivity...                            [ DONE ]
Starting ovirt-engine...                              [ DONE ]
Starting oVirt-ETL...                                 [ DONE ]
Successfully installed rhevm-dwh.
The installation log file is available at: /var/log/ovirt-engine/rhevm-dwh-setup-2014_03_21_12_35_19.log

Version-Release number of selected component (if applicable):
rhevm-dwh-3.3.2-1.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. install engine with remote DB
2. rhevm-dwh-setup
3.

Actual results:
no question about setting remote DB server

Expected results:
give me back the freedom to define remote DB server

Additional info:

Comment 1 Yaniv Lavi 2014-03-23 05:56:23 UTC
No supported for 3.4. will consider this for 3.5.


Yaniv

Comment 2 Yaniv Lavi 2014-05-08 10:14:35 UTC
Should be in for 3.5. Please test this.


Yaniv

Comment 3 Yaniv Lavi 2014-05-08 10:16:13 UTC
Of course  in first 3.5 release.



Yaniv

Comment 7 errata-xmlrpc 2015-02-11 18:14:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0177.html


Note You need to log in before you can comment on or make changes to this bug.