Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078354 - numpy do not build for ppc64le archi
Summary: numpy do not build for ppc64le archi
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: numpy
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-19 16:21 UTC by Michel Normand
Modified: 2014-08-20 09:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 09:32:43 UTC


Attachments (Terms of Use)
numpy_long_double_representation.patch (deleted)
2014-03-19 16:21 UTC, Michel Normand
no flags Details | Diff
numpy-1.8.1.ppc64le.patch (deleted)
2014-04-24 06:25 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-03-19 16:21:40 UTC
Created attachment 876412 [details]
numpy_long_double_representation.patch

Description of problem: numpy do not build for ppc64le archi


Version-Release number of selected component (if applicable):
numpy-1.8.0-5.fc21


Steps to Reproduce:
1. fedpkg clone -a numpy
3. fedpkg mockbuild

Actual results:
...
 Traceback (most recent call last):
      File "setup.py", line 192, in <module>
        setup_package()
    ...
      File "numpy/core/setup_common.py", line 305, in long_double_representation
        raise ValueError("Unrecognized format (%s)" % saw)
    ValueError: Unrecognized format (['001', '043', '105', '147', '211', '253', '315', '357', '000', '000', '000', '124', '064', '157', '235', '301', '000', '000', '000', '000', '000', '000', '000', '0


Additional info:
In attachement numpy_long_double_representation.patch (not yet upstream) is suggested code change to avoid build error.

Comment 1 Michel Normand 2014-03-19 18:21:44 UTC
still pending discussion upstream for the patch to be applied:
https://github.com/numpy/numpy/issues/4516

Comment 2 Michel Normand 2014-04-24 06:25:56 UTC
Created attachment 889192 [details]
numpy-1.8.1.ppc64le.patch

This patch is the backport in 1.8.1 of git commit available in 1.9.0 futur release:
2ba74c3 Adding support of ppc64le architecture

Comment 3 Rex Dieter 2014-05-07 14:24:43 UTC
Patch looks good to me offhand, I'd say it's worth committing a FTBFS fix sooner rather than later (and I'd be happy to help sort out any problems, if there are any).

Comment 4 Jaromír Cápík 2014-05-07 14:44:24 UTC
Thanks Rex ... backport patch pushed and works.


Note You need to log in before you can comment on or make changes to this bug.