Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078330 - Satellite 5.5: CVE name changing syntax in 2014
Summary: Satellite 5.5: CVE name changing syntax in 2014
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 550
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On: 1075990 1078850 1080985 1081189
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-03-19 15:42 UTC by Jan Dobes
Modified: 2016-10-26 20:12 UTC (History)
4 users (show)

Fixed In Version: spacewalk-backend-1.7.38-53 spacewalk-java-1.7.54-126 satellite-schema-5.5.0.22-1
Doc Type: Bug Fix
Doc Text:
Clone Of: 1075990
Environment:
Last Closed: 2014-04-23 12:16:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0428 normal SHIPPED_LIVE spacewalk-backend, spacewalk-java, and spacewalk-schema bug fix update 2014-04-23 16:14:29 UTC
Red Hat Bugzilla 1051682 None None None Never

Comment 3 Pavel Studeník 2014-04-11 12:48:57 UTC
Verified with 
* satellite-schema-5.5.0.22-1.el6sat.noarch.rpm
* spacewalk-java-1.7.54-126.el6sat.noarch
* spacewalk-backend-1.7.38-53.el6sat.noarch

Reproducer was:
0. package satellite-schema-5.5.0.20-1.el6sat
1. satellite-sync -c rhel-x86_64-server-6 --no-rpms --no-packages --no-kickstart
2. mkdir dump
3. rhn-satellite-exporter -c rhel-x86_64-server-6 --dir dump/
4. edit file vim dump/errata/0/rhn-erratum-100.xml.gz
5. satellite-sync -m dump/ -c rhel-x86_64-server-6 --force-all-errata

SYNC ERROR: unhandled exception occurred:

(Check logs/email for potentially more detail)

SQLError(12899, 'ORA-12899: value too large for column "RHNSAT"."RHNCVE"."NAME" (actual: 20, maximum: 13)\n', 'insert into rhnCVE (id, name) values (:id, :name)')
(12899, 'ORA-12899: value too large for column "RHNSAT"."RHNCVE"."NAME" (actual: 20, maximum: 13)\n', 'insert into rhnCVE (id, name) values (:id, :name)')

Comment 5 errata-xmlrpc 2014-04-23 12:16:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0428.html


Note You need to log in before you can comment on or make changes to this bug.