Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078206 - PRD35 - [RFE] [ovirt-hosted-engine-setup] add support for bonded interfaces
Summary: PRD35 - [RFE] [ovirt-hosted-engine-setup] add support for bonded interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Michael Burman
URL:
Whiteboard: network
: 1076947 (view as bug list)
Depends On:
Blocks: 1111162 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-19 11:48 UTC by Evgheni Dereveanchin
Modified: 2018-12-09 17:39 UTC (History)
22 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Enhancement
Doc Text:
Previously, during the hosted engine deployment, selecting a bonded interface to be used as the base for the 'rhevm' bridge would cause the deployment to fail. Now, it is possible to select a bonded interface for the 'rhevm' bridge during hosted engine deployment.
Clone Of:
: 1111162 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:39:47 UTC
oVirt Team: Network
Target Upstream Version:
nyechiel: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 789783 None None None Never
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC
oVirt gerrit 25894 master MERGED packaging: setup: bridge: support tagged VLANs and bond Never

Description Evgheni Dereveanchin 2014-03-19 11:48:23 UTC
Description of problem:
During hosted engine setup, the list of interfaces is provided to use as base for the "rhevm" network. However, if a bond is selected, the setup fails.

Version-Release number of selected component (if applicable):
3.3.1

How reproducible:
always

Steps to Reproduce:
1. set up RHEL server, set up bond0 and rhevm33 repos
2. try to install hosted engine with rhev-m on bond0 ("hosted-engine --deploy")

Actual results:
Setup finishes with error:

[ INFO  ] Configuring the management bridge
[ ERROR ] Failed to execute stage 'Misc configuration': 'bond0'


Expected results:
Setup finishes successfully

Comment 3 Sandro Bonazzola 2014-03-19 15:48:30 UTC
*** Bug 1076947 has been marked as a duplicate of this bug. ***

Comment 10 Sandro Bonazzola 2014-04-17 06:59:04 UTC
patch merged on upstream master for 3.5.0 rebase

Comment 23 Martin Pavlik 2014-08-26 07:33:42 UTC
test failed because during hosted-engine --deploy command host ended up with interfaces setup as onboot = no 

for detailed description see https://bugzilla.redhat.com/show_bug.cgi?id=1128140#c4

Comment 24 Martin Pavlik 2014-09-01 11:04:47 UTC
fail QA until bug 1128140 is resolved

Comment 26 Martin Pavlik 2014-09-09 09:07:03 UTC
fail QA until bug 1128140 is resolved

Comment 28 Martin Pavlik 2014-09-15 07:46:53 UTC
fail QA until bugs 123285 1128140 1139020 are resolved

Comment 29 Michael Burman 2014-10-14 14:47:26 UTC
Verified on - 3.5.0-0.14.beta.el6ev and ovirt-hosted-engine-setup-1.2.1-1.el6ev.noarch

Comment 31 errata-xmlrpc 2015-02-11 20:39:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.