Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 107819 - upgrading glibc wirh rpm -Fvh glibc* destroyed my station
Summary: upgrading glibc wirh rpm -Fvh glibc* destroyed my station
Keywords:
Status: CLOSED DUPLICATE of bug 88456
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-23 12:48 UTC by Sergej Srepfler
Modified: 2016-11-24 15:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:21 UTC


Attachments (Terms of Use)

Description Sergej Srepfler 2003-10-23 12:48:52 UTC
Description of problem:

After manually upgrading a freshly installed RedHatLinux 9.0
system locks down and any further command returns Segmentation fault
System won't boot either.

Version-Release number of selected component (if applicable):
  glibc-2.3.2-27.9.i386.rpm
  glibc-common-2.3.2*
  glibc-debug-2.3.2*
  glibc-devel-2.3.2*
  glibc-profile-2.3.2*
  glibc-utils-2.3.2*

How reproducible:

After issuing a rpm -Fvh glibc*, an error occured and system becomes unstable.

Steps to Reproduce:
1. Freshly installed 9.0
2. Download glibc* from updates.redhat.com
3. rpm -Fvh glibc*
    
Actual results:

Segmentation fault for any command. System won't boot.

Expected results:


Additional info:
Manually upgrading by selecting each rpm and using --nodeps switch work OK.

Comment 1 Brian Zammit 2003-10-27 00:01:21 UTC
I am experiencing the exact same problem. I have repeated this over 10 times on
two different machines with various hardware configurations in each.

Comment 2 Ulrich Drepper 2003-10-27 08:48:13 UTC
You are most definitely replacing a i686 installation with i386 binaries.  Don't
do that.  If you'd have up2date update your machine this wouldn't happen.  If
you do it yourself you better know what you do.

*** This bug has been marked as a duplicate of 88456 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:21 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.