Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078183 - [Neutron integration] Incorrect error message when adding sunbet with wrong CIDR value
Summary: [Neutron integration] Incorrect error message when adding sunbet with wrong C...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
: 3.5.0
Assignee: Lior Vernia
QA Contact: GenadiC
URL:
Whiteboard: network
Depends On:
Blocks: 1063716 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-19 11:00 UTC by GenadiC
Modified: 2016-02-10 19:48 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:12:18 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26746 master MERGED webadmin: Refine CIDR validation message Never

Description GenadiC 2014-03-19 11:00:42 UTC
Description of problem:
If you try to add sunbet for the External network when the value for sunbet value is incorrect (for example 10.10.299.0/27) the error message is complaining on format xxx.xxx.xxx.xxx/xx and not on incorrect value of the fields

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Import or create an External network in RHEV
2. Create Sunbet for that network
3. Fill in incorrect value for subnet and push ok button

Actual results:
An error message "This field must contain a CIDR in format xxx.xxx.xxx.xxx/yy"" is displayed

Expected results:
The message should explain the reason for the failure - incorrect value for subnet field for example

Additional info:

Comment 1 Lior Vernia 2014-04-14 08:45:44 UTC
Was easier to add some details to the current error message than to split it into two distinct messages.

Comment 2 Dan Kenigsberg 2014-05-08 07:36:53 UTC
This bug is not a blocker or an exception forand won't make it for 3.4.0.

Comment 4 GenadiC 2014-07-17 13:04:12 UTC
Verified in 3.5.0-0.0.master.20140715172116.git4687dc1.el6

Comment 6 Eyal Edri 2015-02-17 17:12:18 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.