Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078169 - ibus-m17n build failed with error: po/Makefile.in.in was not created by intltoolize.
Summary: ibus-m17n build failed with error: po/Makefile.in.in was not created by intlt...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-m17n
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Daiki Ueno
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-19 10:17 UTC by Menanteau Guy
Modified: 2014-06-05 04:07 UTC (History)
3 users (show)

Fixed In Version: ibus-m17n-1.3.4-13.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-05 04:07:20 UTC


Attachments (Terms of Use)

Description Menanteau Guy 2014-03-19 10:17:20 UTC
Description of problem:
ibus-m17n build failed with error: po/Makefile.in.in was not created by intltoolize.

Version-Release number of selected component (if applicable):
ibus-m17n-1.3.4
intltool.0.50.2-7.fc21

How reproducible:
rpmbuild -bb

Additional info:
It seems that last changes in intltool makes ibus-m17n failed because
IT_PROG_INTLTOOL and AM_GNU_GETTEXT are now uncompatible.

I used following patch following by an autoreconf to get a successful build.
--- ibus-m17n-1.3.4/configure.ac.ori    
+++ ibus-m17n-1.3.4/configure.ac
@@ -102,8 +102,6 @@ GETTEXT_PACKAGE=ibus-m17n
 AC_SUBST(GETTEXT_PACKAGE)
 AC_DEFINE_UNQUOTED(GETTEXT_PACKAGE,"$GETTEXT_PACKAGE", [Define to the read-only architecture-independent data directory.])

-AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION(0.16.1)


 # OUTPUT files

Comment 1 Daiki Ueno 2014-03-20 03:57:22 UTC
I agree the solution for the meantime, though hopefully intltool will be unnecessary with the next release of gettext.


Note You need to log in before you can comment on or make changes to this bug.