Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078087 - [RFE] Better to filter out nics that was configured to up for nictable of createBondDialog
Summary: [RFE] Better to filter out nics that was configured to up for nictable of cre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1078055 rebase-ovirt-node-3.1 1150377
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-19 07:09 UTC by haiyang,dong
Modified: 2016-02-10 20:11 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1078055
Environment:
Last Closed: 2015-02-11 20:54:11 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
attached Screenshot for createBondDialog (deleted)
2014-03-19 07:09 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC
oVirt gerrit 26626 None None None Never

Description haiyang,dong 2014-03-19 07:09:17 UTC
Created attachment 876236 [details]
attached Screenshot for createBondDialog

+++ This bug was initially created as a clone of Bug #1078055 +++

Description of problem:
Clean install rhevh-6.5-20140317.0.iso, then enter into network page, check that there were three nics "eth0,eth1,eth2",
then configure "eth0" to be up, and then enter into createBondDialog and check that
nictable of createBondDialog will list all nics.(seen createBondDialog.png)
Better to filter out nics that was managed by rhevm or configured for nictable of createBondDialog

Version-Release number of selected component (if applicable):
rhevh-6.5-20140317.0.iso
ovirt-node-3.0.1-18.el6_5.8.noarch

How reproducible:
100%

Steps to Reproduce:


Actual results:


Expected results:

Comment 3 Fabian Deutsch 2014-04-08 11:33:00 UTC
In a discussion with vdsm people it was suggested to mark the superfluous bonds as Managed or Owned.

Hiding them could irritate people when they expect them. By marking them it is at lest signaled tht they are expected.

Comment 4 Ryan Barry 2014-04-08 13:19:52 UTC
Is this still relevant if we're not going to show users the option to create bonds if managed?

https://bugzilla.redhat.com/show_bug.cgi?id=1083138

Comment 5 haiyang,dong 2014-04-09 02:45:50 UTC
(In reply to Ryan Barry from comment #4)
> Is this still relevant if we're not going to show users the option to create
> bonds if managed?
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1083138

at least it was necessary for Better to filter out nics that was configured to up for nictable of createBondDialog since we're not going to show users the option to create bonds if managed.

Comment 6 Ryan Barry 2014-04-09 14:24:23 UTC
Ok, so we're now filtering NICs which are configured from the bond dialog.

Comment 7 Fabian Deutsch 2014-07-24 16:02:33 UTC
This is a mass change, moving bugs of merged patches into MODIFIED.

Please correct the state, if you think that the move was not justified.

Comment 9 haiyang,dong 2014-11-17 07:09:51 UTC
Test version:
rhev-hypervisor6-6.6-20141107.0.iso
ovirt-node-3.1.0-0.25.20141107gitf6dc7b9.el6.noarch

Test steps:
1. Clean install rhev-hypervisor6-6.6-20141107.0.iso
2. then enter into network page, check that there were three nics "eth0,eth1,eth2",then configure "eth0" to be up, 
3. then enter into createBondDialog and check that
nictable of createBondDialog will list reconfigured nics(eth1,eth2)

so now nictable of createBondDialog filter out nics that was configured to up.

Also i noticed that when rhevh nic that was managed by rhevm, the <Create Bond> button will be disabled from rhevh setup menu.

so this bug has been fixed in in rhevh 6.6 for RHEV 3.5 bulid version, change the status into "VERIFIED".

Comment 11 errata-xmlrpc 2015-02-11 20:54:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.