Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1078055 - [RFE] Better to filter out nics that was managed by rhevm or configured for nictable of createBondDialog
Summary: [RFE] Better to filter out nics that was managed by rhevm or configured for n...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Ryan Barry
QA Contact: Petr Kubica
URL:
Whiteboard: node
Depends On: 1149655 1149658
Blocks: 1078087
TreeView+ depends on / blocked
 
Reported: 2014-03-19 06:13 UTC by haiyang,dong
Modified: 2016-02-10 19:40 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1078087 (view as bug list)
Environment:
Last Closed: 2014-11-17 17:18:37 UTC
oVirt Team: Node


Attachments (Terms of Use)
attached Screenshot for createBondDialog (deleted)
2014-03-19 06:13 UTC, haiyang,dong
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26339 None None None Never
oVirt gerrit 26626 None None None Never

Description haiyang,dong 2014-03-19 06:13:14 UTC
Created attachment 876225 [details]
attached Screenshot for createBondDialog

Description of problem:
Clean install rhevh-6.5-20140317.0.iso, then enter into network page, check that there were three nics "eth0,eth1,eth2",
then configure "eth0" to be up, and then enter into createBondDialog and check that
nictable of createBondDialog will list all nics.(seen createBondDialog.png)
Better to filter out nics that was managed by rhevm or configured for nictable of createBondDialog

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.4-1.0.201401291204.vdsm34rc2.el6.iso

How reproducible:
100%

Steps to Reproduce:


Actual results:


Expected results:

Comment 1 Ryan Barry 2014-04-10 15:03:58 UTC
The combination of not showing NICs which are configured (https://bugzilla.redhat.com/show_bug.cgi?id=1078087) and not allowing users to create new bonds when managed by RHEV-M (https://bugzilla.redhat.com/show_bug.cgi?id=1083138) will resolve.

I'd like to close this as a duplicate.

Comment 2 haiyang,dong 2014-04-13 04:24:33 UTC
(In reply to Ryan Barry from comment #1)
> The combination of not showing NICs which are configured
> (https://bugzilla.redhat.com/show_bug.cgi?id=1078087) and not allowing users
> to create new bonds when managed by RHEV-M
> (https://bugzilla.redhat.com/show_bug.cgi?id=1083138) will resolve.
> 
> I'd like to close this as a duplicate.

I report this bug in ovirt-node upstream component, since there two branches for upstream and downstream for ovirt-node, i think it's better to keep this bug as open to track this issue in upstream

Comment 3 Ryan Barry 2014-04-13 11:09:14 UTC
Since downstream mirrors upstream, the relevant patches for those bugs are already present:

http://gerrit.ovirt.org/#/c/26626/
http://gerrit.ovirt.org/#/c/26339/

Users will not be able to see configured NICs in the createBond dialog or use the createBond dialog when registered to ovirt-engine upstream either. It'll still be an unresolvable bug when those patches merge, and the issue will not exist upstream.

Comment 4 Petr Kubica 2014-10-15 20:02:28 UTC
Verified in rhev-hypervisor6-6.6-20141007.0


Note You need to log in before you can comment on or make changes to this bug.