Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1077775 - [RHEVM-SETUP] - reports upgrade fails due to missing war
Summary: [RHEVM-SETUP] - reports upgrade fails due to missing war
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On: 1086003 1111749 1121792
Blocks: 1071020 rhev3.4snapshot2
TreeView+ depends on / blocked
 
Reported: 2014-03-18 14:45 UTC by Barak Dagan
Modified: 2018-12-06 16:07 UTC (History)
18 users (show)

Fixed In Version: av5 - rhevm-reports-3.4.0-4.el6ev.noarch.rpm
Doc Type: Bug Fix
Doc Text:
Previously, upgrading from Red Hat Enterprise Virtualization 3.3 to Red Hat Enterprise Virtualization 3.4 would fail under certain conditions due to a missing .war file when the Reports feature was installed. This was caused by the logic used to specify the location of the JasperReports .war file. This logic has now been revised so that the location of the JasperReports .war file is detected correctly, allowing the upgrade to complete successfully.
Clone Of:
Environment:
Last Closed: 2014-07-23 12:19:37 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
setup log (deleted)
2014-03-18 14:45 UTC, Barak Dagan
no flags Details
setup log (deleted)
2014-03-18 15:56 UTC, Barak Dagan
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0602 normal SHIPPED_LIVE rhevm-reports 3.4 bug fix and enhancement update 2014-06-09 19:26:10 UTC
oVirt gerrit 26005 None None None Never

Description Barak Dagan 2014-03-18 14:45:05 UTC
Created attachment 875960 [details]
setup log

Description of problem:
during upgrade from 3.3 machine with reports installed to 3.4 (2 pahses: engine, then  dwh & reports), the installation fails in the reports upgarde part:

[ INFO  ] Backing up database localhost:ovirt_engine_history to '/var/lib/ovirt-engine-dwh/backups/dwh-20140318193421.PiimQx.sql'.
[ INFO  ] Creating/refreshing DWH database schema
[ INFO  ] Exporting data out of Jasper
[ ERROR ] Failed to execute stage 'Misc configuration': Could not detect Jasper war folder
[ INFO  ] Rolling back database schema
[ INFO  ] Clearing Engine database engine
[ INFO  ] Restoring Engine database engine
[ INFO  ] Rolling back DWH database schema
[ INFO  ] Clearing DWH database ovirt_engine_history
[ INFO  ] Restoring DWH database ovirt_engine_history
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140318193226.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


Version-Release number of selected component (if applicable):
av3

How reproducible:
1 / 1

Steps to Reproduce:
1. install 3.3 + dwh  & reports
2. upagrde to 3.4 engine
3. yum update dwh & reports
4. run rhevm-setup again

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Lavi 2014-03-18 15:42:11 UTC
Log is corrupt, please reattach.


Yaniv

Comment 2 Barak Dagan 2014-03-18 15:56:36 UTC
Created attachment 876013 [details]
setup log

Comment 3 Yaniv Lavi 2014-03-19 19:40:05 UTC
Didi, I'm not sure we take the old 3.3 war location from environment.
Please check this. The pro config file for setup is in d\s gerrit rhev-3.4 branch.
Alon can help you with more details.




Yaniv

Comment 4 Yaniv Lavi 2014-03-23 05:05:19 UTC
Didi, please provide update. This is blocking upgrade tests.



Yaniv

Comment 6 Barak Dagan 2014-04-24 15:04:44 UTC
Verified on av6.1

Comment 7 errata-xmlrpc 2014-06-09 15:28:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0602.html


Note You need to log in before you can comment on or make changes to this bug.