Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1077767 - OCaml add ppc64le support to the compiler
Summary: OCaml add ppc64le support to the compiler
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1077701 1078190 (view as bug list)
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker 1078190 1083616 1085850
TreeView+ depends on / blocked
 
Reported: 2014-03-18 14:26 UTC by Michel Normand
Modified: 2014-08-20 09:24 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-20 09:24:39 UTC


Attachments (Terms of Use)
ocaml.ppc64.bytecode.patch (deleted)
2014-03-18 14:26 UTC, Michel Normand
no flags Details | Diff
ocaml.ppc64le.step1.patch (deleted)
2014-04-09 15:28 UTC, Michel Normand
no flags Details | Diff
ocaml.spec.ppc64le.step1.patch (deleted)
2014-04-09 15:29 UTC, Michel Normand
no flags Details

Description Michel Normand 2014-03-18 14:26:09 UTC
Created attachment 875956 [details]
ocaml.ppc64.bytecode.patch

Description of problem: ocaml package do not build with new ppc64le archi


Version-Release number of selected component (if applicable):
ocaml-4.01.0-8.fc21

How reproducible:


Steps to Reproduce:
1. fedpkg -a ocaml
2. fedpkg prep
3. fedpkg mockbuild

Additional info:

refer to ocaml.ppc64.bytecode.patch to solve the problem

Comment 1 Michel Normand 2014-04-09 15:28:38 UTC
Created attachment 884551 [details]
ocaml.ppc64le.step1.patch

ocaml.ppc64le.step1.patch referenced in ocaml.spec  as per second attachment ocaml.spec.ppc64le.step1.patch

Comment 2 Michel Normand 2014-04-09 15:29:37 UTC
Created attachment 884552 [details]
ocaml.spec.ppc64le.step1.patch

Comment 3 Richard W.M. Jones 2014-04-09 16:36:12 UTC
*** Bug 1078190 has been marked as a duplicate of this bug. ***

Comment 4 Richard W.M. Jones 2014-04-09 16:40:34 UTC
I've pushed the whole patch (as a single commit) to the
Fedora OCaml repo:

https://git.fedorahosted.org/git/fedora-ocaml.git

And added it to ocaml-4.01.0-12:

http://pkgs.fedoraproject.org/cgit/ocaml.git/commit/?id=a0eedc071fa49fd04793d6bc0d939effb6f8e857

Comment 5 Michel Normand 2014-04-10 13:34:05 UTC
*** Bug 1077701 has been marked as a duplicate of this bug. ***

Comment 6 Michel Normand 2014-08-20 09:24:39 UTC
closed as fixed with patch since ocaml-4.01.0-12


Note You need to log in before you can comment on or make changes to this bug.