Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1077701 - ocaml-camomile do not build on ppc64le without native compiler
Summary: ocaml-camomile do not build on ppc64le without native compiler
Keywords:
Status: CLOSED DUPLICATE of bug 1077767
Alias: None
Product: Fedora
Classification: Fedora
Component: ocaml-camomile
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard W.M. Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-18 12:46 UTC by Michel Normand
Modified: 2014-04-10 13:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-10 13:34:05 UTC


Attachments (Terms of Use)
ocaml-camomile.make.byte.patch (deleted)
2014-03-18 12:46 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-03-18 12:46:51 UTC
Created attachment 875919 [details]
ocaml-camomile.make.byte.patch

Description of problem: unable to build ocaml-camomile package for ppc64le archi
that do not support yet native ocaml compiler.

Version-Release number of selected component (if applicable):
ocaml-camomile-0.8.3-13.fc21

Steps to Reproduce:
1. fedpkg -a clone ocaml-camomile 
2. fedpkg prep
3. fedpkg mockbuild

Actual results:
===
...
ocamlc -a -o camomileLibrary.cma public/unicodeString.cmo configInt.cmo internal/uReStrParserType.cmo internal/database.cmo camomileDefaultConfig.cmo internal/bitsvect.cmo internal/bytesvect.cmo internal/avlTree.cmo internal/iSet.cmo internal/iMap.cmo internal/tbl31.cmo internal/byte_labeled_dag.cmo internal/xArray.cmo public/oOChannel.cmo public/uChar.cmo public/uSet.cmo public/uMap.cmo public/uCharTbl.cmo public/uText.cmo public/xString.cmo public/subText.cmo public/uLine.cmo public/locale.cmo internal/hangul.cmo internal/unidata.cmo internal/charmap.cmo internal/unimap.cmo public/charEncoding.cmo public/uTF8.cmo public/uTF16.cmo public/uCS4.cmo public/uPervasives.cmo public/uCharInfo.cmo public/uNF.cmo public/uCol.cmo public/caseMap.cmo public/uRe.cmo internal/uReStrParser.cmo internal/uReStrLexer.cmo public/uReStr.cmo internal/stringPrep_data.cmo public/stringPrep.cmo camomileLibrary.cmo
no -c -noassert -I internal -I public -I toolslib -I . -g -impl public/unicodeString.mli            
make: no: Command not found                                                                         
make: *** [public/unicodeString.cmx] Error 127                                                      
===


Additional info:

The attached patch on spec file, allow to build only the bytecode.

Comment 1 Richard W.M. Jones 2014-03-18 12:59:49 UTC
Has anyone looked at what it would take to port the native compiler?

There is no upstream source for the ppc64 backend.  We maintain
it ourselves here:
https://git.fedorahosted.org/cgit/fedora-ocaml.git/commit/?id=a85437a0d2ffdf7a340d379789500eb583ae4708

Comment 2 Michel Normand 2014-04-10 13:34:05 UTC
now that ppc64le native compiler is supported by rhbz#1077767
there is no more need of those changes, so set this bug as dup.

*** This bug has been marked as a duplicate of bug 1077767 ***


Note You need to log in before you can comment on or make changes to this bug.