Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1077627 - Incorrect error message when VM start fails
Summary: Incorrect error message when VM start fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Martin Sivák
QA Contact: GenadiC
URL:
Whiteboard: sla
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-18 10:39 UTC by GenadiC
Modified: 2016-02-10 20:16 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.5.0-alpha2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:09:00 UTC
oVirt Team: SLA
Target Upstream Version:


Attachments (Terms of Use)
print screen with the second issue explained (deleted)
2014-03-18 10:39 UTC, GenadiC
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26620 master MERGED engine: Improve messages in scheduling Never
oVirt gerrit 26621 master MERGED webadmin: Replace inner variable references in failure messages Never

Description GenadiC 2014-03-18 10:39:00 UTC
Created attachment 875866 [details]
print screen with the second issue explained

Description of problem:
If you want to start VM that can't be run for some reason on any host in the setup an error message is missing inoformation sometimes and sometimes present information in unclear way. For example if you start VM when the host that could run it is in maintenance you get the following: "Cannot run VM. There is no host that satisfies current scheduling constraints. See below for details:" but there are no details after ":" mark

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create VM that could run on Host A
2. Put host A in maintenance and try to start VM
3.

Actual results:
"Cannot run VM. There is no host that satisfies current scheduling constraints. See below for details:"

Expected results:
If you want to give details for the failure, please do, otherwise remove See below for details message

Additional info:
Another scenario - Having host that couldn't run VM because it doesn't have all the networks attached that the VM has.
Trying to start such a VM you get the following:
   * Cannot run VM. There are no available running Hosts with all the networks used by the VM.
   * Cannot run VM. There is no host that satisfies current scheduling constraints. See below for details:
   * The host silver-vdsb.qa.lab.tlv.redhat.com did not satisfy internal filter Network.

Cannot run VM shouldn't appear twice.
The message after See below details should be tabbed as it explains the second line

Comment 1 Doron Fediuck 2014-03-24 14:18:30 UTC
Genadi, you actually attach a different scenario than your description.

I see 2 issues here:
- Your initial description which says there's no host available. Is this
something you saw and can reproduce?

- The network scenario is valid, but missing the network name which is insufficient.

Comment 2 GenadiC 2014-03-24 14:28:07 UTC
yes - create VM and put host into maintenance and then try to start a VM

Comment 3 GenadiC 2014-07-03 07:32:02 UTC
Verified in 3.5.0-0.0.master.20140629172257.git0b16ed7.el6

Comment 5 Eyal Edri 2015-02-17 17:09:00 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.