Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1076944 - PRD35 - [RFE] Hosted Engine deploy should support VLAN-tagged interfaces
Summary: PRD35 - [RFE] Hosted Engine deploy should support VLAN-tagged interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 3.3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: 3.5.0
Assignee: Sandro Bonazzola
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On: 1072027 1123285 1128140
Blocks: 1117634 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-16 17:33 UTC by Nir Yechiel
Modified: 2016-02-10 19:57 UTC (History)
23 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Enhancement
Doc Text:
Previously, during the hosted engine deployment, selecting a VLAN-tagged network interface to be used as the base for the 'rhevm' bridge would cause the deployment to fail. Now, it is possible to select a VLAN-tagged network interface for the 'rhevm' bridge during hosted engine deployment.
Clone Of: 1072027
: 1117634 (view as bug list)
Environment:
Last Closed: 2015-02-11 20:39:39 UTC
oVirt Team: Network
Target Upstream Version:
nyechiel: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0161 normal SHIPPED_LIVE ovirt-hosted-engine-setup bug fix and enhancement update 2015-12-07 21:35:11 UTC
oVirt gerrit 25894 master MERGED packaging: setup: bridge: support tagged VLANs and bond Never
Red Hat Bugzilla 1124207 None None None Never

Internal Links: 1124207

Description Nir Yechiel 2014-03-16 17:33:38 UTC
+++ This bug was initially created as a clone of Bug #1072027 +++

Description of problem:

When running ovirt-hosted-engine-setup on hosts (CentOS 6.5) with VLAN tagged interfaces it fails with the following error message:

2014-02-25 15:35:20 INFO
otopi.plugins.ovirt_hosted_engine_setup.network.bridge bridge._misc:189
Configuring the management bridge
2014-02-25 15:35:20 DEBUG otopi.context context._executeMethod:152
method exception
Traceback (most recent call last):
   File "/usr/lib/python2.6/site-packages/otopi/context.py", line 142,
in _executeMethod
     method['method']()
   File
"/usr/share/ovirt-hosted-engine-setup/scripts/../plugins/ovirt-hosted-engine-setup/network/bridge.py",
line 194, in _misc
     ].s.getVdsCapabilities()['info']['nics'][nics]
KeyError: 'eth0.200'


Version-Release number of selected component (if applicable):
ovirt-hosted-engine-setup-1.1.0-1.el6.noarch

How reproducible:
Trying to use vlan tagged interface as ovirtmgmt network in ovirt-hosted-engine-setup


Steps to Reproduce:
1. Install CentOS 6.5 with vlan tagged interface (e.g. eth0.200)
2. Run ovirt-hosted-engine-setup and choose interface eth0.200 for ovirtmgmt interface

Actual results:
ovirt-hosted-engine-setup fails with error message posted above

Expected results:
Create ovirtmgmt-interface with VLAN tag

Additional info:
If I remove the VLAN tag setup is working fine, but if you need VLAN tags you have to do the following to make it work:

- Set switch port to untagged for this VLAN
- Configure eth0 instead of eth0.200
- Run hosted engine setup
- Configure VLAN for ovirtmgmt in oVirt (which surprisingly worked for
an active interface)
- Configure VLAN tagging on hosts
- Reconfigure switch ports
- Sync networks in oVirt network setup tab

Adding support for VLAN tagged interfaces into ovirt-hosted-engine-setup would make live much easier.

--- Additional comment from Sandro Bonazzola on 2014-03-04 02:29:23 EST ---

Rene, thanks for both the report and the provided workaround!

Comment 1 Sandro Bonazzola 2014-04-17 06:56:06 UTC
merged on upstream master for 3.5.0 rebase

Comment 4 Sandro Bonazzola 2014-06-19 11:56:33 UTC
Proposing this for ZStreaming. The patch solving this is the same used for solving bug #1078206 already on ZStream.

Comment 8 Michael Burman 2014-07-28 10:15:30 UTC
Verified on-ovirt-hosted-engine-setup-1.1.3-2.el6ev.noarch


After installation, the host status is up, but rhevm network is not synced.
If this should be the behavior, then it's should be documented in the admin guide.

Comment 9 Michael Burman 2014-07-28 11:37:07 UTC
By mistake changed to verified on 3.5, when actually verified on 3.4.1 av10.5
Changing back to ON_QA

Comment 11 Michael Burman 2014-07-28 12:05:57 UTC
Once RHEV-M is up, i can solve the sync issue by edit the logical 'rhevm' network and set the VLAN ID. after updating the network, in [setup networks], the 'rhevm' network is synced.

Comment 12 Michael Burman 2014-07-28 14:28:56 UTC
QAFailed on version- ovirt-hosted-engine-setup-1.2.0-0.1.master.el6.noarch

Blocked by 1123285

Comment 13 Lior Vernia 2014-07-31 12:51:29 UTC
To my understanding doesn't require any additional work on this bug specifically, so let's keep it ON_QA until it can be verified (if blocking bugs are VERIFIED and this doesn't work, please put it back on ASSIGNED).

Comment 14 Martin Pavlik 2014-08-11 13:25:04 UTC
for 3.5 rc testing is blocked by bug 1128140 which makes setup stuck in phase 
[ INFO  ] Configuring the management bridge

Comment 15 Michael Burman 2014-08-25 13:53:32 UTC
Verified on -  oVirt Engine Version: 3.5.0-0.0.master.20140821064931.gitb794d66.el6 

Important- After installation, the host status is up, but rhevm/ovirtmgmt network is not synced.
If this should be the behavior, then it's should be documented in the admin guide.

Once RHEV-M is up, i can solve the sync issue by edit the logical 'rhevm' network and set the VLAN ID. after updating the network, in [setup networks], the 'rhevm' network is synced.

Comment 16 Martin Pavlik 2014-08-25 14:18:11 UTC
for comment 15 bug 1124207 was opened

Comment 18 errata-xmlrpc 2015-02-11 20:39:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0161.html


Note You need to log in before you can comment on or make changes to this bug.