Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1076904 - [Neutron integration] Incorrect error message when remove network from Neutron provider fails
Summary: [Neutron integration] Incorrect error message when remove network from Neutro...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Moti Asayag
QA Contact: GenadiC
URL:
Whiteboard: network
Depends On:
Blocks: 1063716 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-16 11:39 UTC by GenadiC
Modified: 2016-02-10 19:53 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 11:05:12 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)

Description GenadiC 2014-03-16 11:39:42 UTC
Description of problem:
If you try to remove network from RHEV setup and from Neutron simultaneously when that network doesn't exist on Neutron, you get an error message "Failed to remove Network <network_name> from Data Center: <DC_NAME>" in the Events tab, though the failure is in remove from Neutron Server as the network doesn't exists there

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create network red on DC and Neutron from GUI
2. Remove network from neutron by running neutron net-delete <id> command on the Neutron Server
3. Try to remove that network from GUI when "Remove external network(s) from the provider(s) as well" checkbox is checked

Actual results:
Action fails on Failed to remove Network <network_name> from Data Center: <DC_NAME>" error in Events tab

Expected results:
It should be pop-up with an error that action failed to remove network on Neutron Server

Additional info:

Comment 1 Moti Asayag 2014-07-23 11:05:12 UTC
When an external network is being removed from a provider, the provider is being accessed only during the execution of the action.

Therefore it is too late in the flow to bump a popup with a message.
The reason for not accessing the provider during the command validation is to prevent it from hung the webadmin for the entire time.


Note You need to log in before you can comment on or make changes to this bug.