Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1076400 - libhugetlbfs support ppc64le
Summary: libhugetlbfs support ppc64le
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libhugetlbfs
Version: rawhide
Hardware: ppc64le
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: emunson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-14 10:11 UTC by Michel Normand
Modified: 2014-04-17 06:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-17 06:36:55 UTC


Attachments (Terms of Use)
libhugetlbfs-2.17_ppc64le.patch (deleted)
2014-03-14 10:11 UTC, Michel Normand
no flags Details | Diff
libhugetlbfs.spec.2.18.patch (deleted)
2014-04-07 08:42 UTC, Michel Normand
no flags Details | Diff

Description Michel Normand 2014-03-14 10:11:02 UTC
Created attachment 874307 [details]
libhugetlbfs-2.17_ppc64le.patch

Description of problem: current 2.17 version do not support ppc64le archi

The required patches are available upstream after tag 2.17

Steps to Reproduce:
1. fedpkg clone -a libhugetlbfs
2. fedpkg prep
3. fedpkg mockbuild

Additional info:

I am providing in attachment the related patch that could be use for 2.17 tarball.

Comment 1 emunson 2014-03-15 00:51:25 UTC
I have merged this into the next branch of libhugetlbfs and it will be part of the 2.18 release.  Meanwhile, when I get my fedora box back up and running (hopefully later tonight) I will roll this patch into the 2.17 package.

Comment 2 emunson 2014-03-16 02:54:13 UTC
2.17-2 is in rawhide.  Let me know if you need it pushed into F20.

Comment 3 Michel Normand 2014-03-28 14:43:45 UTC
The referenced patch in attachment was incorrectly merged at least for 2.17-2:

* the referenced patch was a git patch for fedora libhugetlbfs git tree.
* but has been used as a Patch2 in spec file (which is incorrect)
  and without trying to apply it  (there is no %patch2 in %prep section)

Comment 4 emunson 2014-04-06 17:08:17 UTC
Released 2.18 and built to rawhide.

Comment 5 Michel Normand 2014-04-07 08:42:33 UTC
Created attachment 883505 [details]
libhugetlbfs.spec.2.18.patch

with update to 2.18, need to remove the ppc patch from spec file.
the libhugetlbfs.spec.2.18.patch is the related spec change.

Comment 6 emunson 2014-04-07 21:52:46 UTC
Done for 2.18-2 in rawhide


Note You need to log in before you can comment on or make changes to this bug.