Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1076220 - RHEV-toolsSetup_3.3_11 installation failed on a windows 2012 R2 Standard x86_64 with "No supported OS was detected. Aborting installation" error message.
Summary: RHEV-toolsSetup_3.3_11 installation failed on a windows 2012 R2 Standard x86_...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Windows Guest Tools
Version: 3.3.0
Hardware: x86_64
OS: Windows
high
high
Target Milestone: ---
: 3.5.0
Assignee: Lev Veyde
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On:
Blocks: 1117213 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-13 19:44 UTC by Udayendu Sekhar Kar
Modified: 2018-12-06 16:09 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, Windows Server 2012 R2 was unsupported in Red Hat Enterprise Virtualization 3.3, so no guest tools can be installed for Windows Server 2012 R2 using the RHEV 3.3 installer. With this update, support for Windows Server 2012 R2 and Windows 8.1 has been added and is now supported in Red Hat Enterprise Virtualization 3.4 and Red Hat Enterprise Virtualization 3.5.
Clone Of:
: 1117213 (view as bug list)
Environment:
Last Closed: 2015-02-11 17:41:15 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 784443 None None None Never
Red Hat Product Errata RHEA-2015:0198 normal SHIPPED_LIVE rhev-guest-tools-iso bug fix and enhancement update 2015-02-11 22:34:00 UTC

Description Udayendu Sekhar Kar 2014-03-13 19:44:41 UTC
Description of problem:
RHEV-toolsSetup_3.3_11 installation failed on a windows 2012 R2 Standard x86_64 with "No supported OS was detected. Aborting installation" error message. Following error messages were available in the "Install.RHEV-tools.log" file:

----
AmIUpgrade : it is NOT an upgrade  Status: La operación se completó correctamente.
OS Major Ver = (6), OS Minor Ver = (3) Status: Information
OSVer = (603), Wow64 = (1), ProductType = (3) Status: Information
No supported OS was detected. Aborting installation. Status: Information
The installation is aborted Status: Information
----

Version-Release of selected component (if applicable):
RHEVM 3.3
RHEV-toolsSetup_3.3_11
Windows 2012 R2 x86_64 Standard

How reproducible:
Everytime in customer's environment.

Steps to Reproduce:
1.
2.
3.

Actual results:
Installation fail.

Expected results:
Should be able to install.

Comment 3 Michal Skrivanek 2014-03-25 09:20:15 UTC
this is an issue in installer, not guest agent

Comment 4 Lev Veyde 2014-03-25 12:38:52 UTC
That is because we yet to support Windows 8.1 and Windows 2012 R2 in RHEV 3.3, and I'm not sure we will support it.

Comment 14 Jiri Belka 2014-08-05 14:24:01 UTC
ok, 3.5.1

Comment 17 errata-xmlrpc 2015-02-11 17:41:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0198.html


Note You need to log in before you can comment on or make changes to this bug.