Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1075903 - [RFE]Add ovirt-node-config commandline tool to configure Node.
Summary: [RFE]Add ovirt-node-config commandline tool to configure Node.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1075902 rebase-ovirt-node-3.1
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-13 07:38 UTC by haiyang,dong
Modified: 2016-02-10 20:07 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1075902
Environment:
Last Closed: 2015-02-11 20:53:45 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2014-03-13 07:38:04 UTC
+++ This bug was initially created as a clone of Bug #1075902 +++

Description of problem:
ovirt-node-config is a commandline tool to configure Node.
Basically the tool exposes the classes of ovirt-node.config.defaults.
That way the system can basically configured using the commandline. The
same codepaths are shared between the CLI and TUI.
This is mainly intended for quality issue to check all codepaths.
Some examples:
General help:
$ ovirt-node-config -h
Help on a class:
$ ovirt-node-config help IPv6
Help on a function:
$ ovirt-node-config help IPv6.configure_dhcp
Run a function:
$ ovirt-node-config run IPv6.configure_dhcp
$ ovirt-node-config run Network.configure_static ens3 1.2.3.4 255.0.0.0
1.2.3.254

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 haiyang,dong 2014-03-13 07:38:19 UTC
clone this REF bug form upstream to also track it in rhevh

Comment 5 haiyang,dong 2014-10-13 06:40:50 UTC
Test version:
rhevh-7.0-20141006.0.el7ev.iso
ovirt-node-3.1.0-0.20.20141006gitc421e04.el7.noarch

Test steps:
1.[root@dhcp-8-124 admin]# ovirt-node-config h
Usage: ovirt-node-config [options] help|run [<CLASS>[.<FUNC> [<ARG> [<ARG>] ...]]]]

Options:
  -h, --help            show this help message and exit
  -m MODULE, --module=MODULE
                        Module to use
  --dry                 Enable dry mode
  --config=CFGFILE      Config file to use

Available classes in module 'ovirt.node.config.defaults':
- Collectd
- ConfigVersion
- Hostname
- IPv6
- Installation
- KDump
- Keyboard
- Logrotate
- Management
- NFSv4
- Nameservers
- Netconsole
- Network
- NetworkLayout
- NicBonding
- NodeConfigFileSection
- RuntimeImageState
- SCSIDhAlua
- SSH
- Syslog
- Timeservers
- iSCSI

2. [root@dhcp-8-124 admin]# ovirt-node-config h KDump
Functions in class 'KDump':

- configure_disable 
- configure_local 
- configure_nfs <NFS_LOCATION>
- configure_ssh <SSH_LOCATION> [<SSH_KEY=None>]

3.[root@dhcp-8-124 admin]# ovirt-node-config run KDump.configure_disable
Configuring kdump
-----------------
Checking pre-conditions ...
(1/3) Backing up config files
(2/3) Removing set kdump options
(3/3) Removing kdump backup

All changes were applied successfully.
[root@dhcp-8-124 admin]# ovirt-node-config run KDump.configure_local
Configuring kdump
-----------------
Checking pre-conditions ...
(1/4) Backing up config files
(2/4) Removing set kdump options
(3/4) Setting local kdump config
(4/4) Restarting kdump service

All changes were applied successfully.

4. [root@dhcp-8-124 admin]# ovirt-node-config help Hostname
Functions in class 'Hostname':

- configure_hostname <HOSTNAME>
Configure the hostname of this system
Args:
    hostname: Hostname to be set
[root@dhcp-8-124 admin]# ovirt-node-config run Hostname.configure_hostname redhat
Configuring hostname
--------------------
Checking pre-conditions ...
(1/1) Setting hostname

All changes were applied successfully.
[root@dhcp-8-124 admin]# hostname
redhat

so add ovirt-node-config commandline tool to configure Node basic functions feature can work well. change the status into "VERIFIED".

Comment 7 errata-xmlrpc 2015-02-11 20:53:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.